Times of tracks don't match up when exported

as i record a vocal track to an instrumental track… everything lines up fine

after i export both tracks and plug them into a different program

the tracks suddenly become off-beat to each other

it’s as if when exported… an extra second or two of blank space gets added to only one of the tracks… making them off sync

how can i fix this thanks :slight_smile:

When overdubbing, Audacity pushes the newly recorded track backwards after you stop the recording. You can adjust that correction at “Latency correction” in the Recording Preferences.

Perhaps you did not notice that correction happened, or perhaps that correction pushed some tracks behind time zero. Audio behind zero is not exported by standard export so that would cause desynchronisation. To correct audio behind zero, Edit > Select > All, hold SHIFT and press HOME, then Tracks > Align Tracks > Start to Zero.

Please note we are in the dark about your operating system and version of Audacity. It is better to look at the pink panel at the top of the page and post in the board for your operating system.


Gale

thanks i’ll try it next time i record

i did try to do what u said to an already recorded project… but it didn’t correct the error

i put both latency options to 0…

and i aligned tracks to 0… exported them again… lined them up in new program… and both tracks are still out of sync with each other

i also did sync-lock tracks… that didn’t work

… now this could be because im applying these changes to an already recorded track…

but i’ll try again next time to input these preferences before i even record, and i’ll see what happens in the end :slight_smile:

thanks a lot for your help :slight_smile: have a nice day

I suggest you read the Manual: http://manual.audacityteam.org/o/man/recording_preferences.html. If you set Audio to buffer to zero you will not be able to play or record anything.

If the tracks are aligned correctly when you export then realigning them in another application will desynchronise them.

Are you exporting as MP3? Don’t. MP3 adds silence padding to the start of each track due to limitations in the format. It’s also lossy. Export as WAV.

That does not correct existing misalignment: http://manual.audacityteam.org/o/man/sync_locked_track_groups.html. When Sync-Lock Tracks is on it preserves the existing synchronisation when you make changes that affect synchronisation.

If you need any more help we would appreciate if you would state your operating system and version of Audacity and see if you can give us exact steps for what you do after you stop recording the second track.


Gale