Timer Recordings stop after 2 hours post Audacity 3.2.4 upgrade

I was using Audacity v2X with Timer Recordings to record 4 hours of last night Coast to Coast AM radio using the TuneIn app on my Windows 10 computer. It was working fine. I just updated to Audacity v3.2.4 a few days ago and now the Timer Recordings stop at 2 hours and 12 minutes for some reason.

I checked my free disk space and Audacity states there are over 52 hours of recording time on my SSD.

The TuneIn app is still running fine when I check the computer, but for some reason Audacity has stopped recording at the 2 hour 12 minute point.

I notice that the new v3.2.4 of Audacity uses .aup3 file instead of the v2X .aup directories.

The only add ons I have installed since updating Audacity are FFMpeg, but the problem with the Audacity recordings stopping on their own started before I installed FFMpeg.

Any other complaints about this issue of recordings stopping after 2 hours? Can I roll back or reinstall an old version of Audacity that worked?

Appreciate any help. Thanks in advance.

Every week on Monday nights I run a 2h 15m Timer Record Project - it always works fine and does not stop at 2h 12m

Next week I can try slightly longer.

W10 always using latest released Audacity version


I am continuing to troubleshoot this issue. I suspect it may be the TuneIn app that is timing out, stops live playing after 2 hours, which is causing Audacity to stop recording.

I am now leaning towards the TuneIn app being the problem because yesterday I attempted to record live radio off TuneIn and it would stop playing at random times even though I was able to verify that Audacity was still waiting for an input signal. TuneIn would stop play at anything from 45 minutes to an hour and a half, so the 2 hour 12 minute limit I thought I was seeing may not be true at all. Even though TuneIn displayed it was broadcasting live radio, there was no signal. I had to stop and restart TuneIn for the radio station to restart the broadcast. Audacity immediately started recording when the broadcast signal was reset.

Tonight, I am using a different radio internet app to see if the timer recording in Audacity captures the entire 4 hours of radio program. I’ll update this thread if/when I can verify that the problem was not Audacity. As of now, I think the problem is not with Audacity.

Also, I am checking my other Windows 10 settings like screen timeout, etc… Sometimes, with Windows, the answer might be some hidden issue that one never thinks of that is causing a problem.

Everything worked fine last night using a different internet radio app. Got all 4 hours of the program recorded. Appears that the TuneIn app was causing my problems with recordings cutting off half way and had nothing to do with Audacity.

Consider this issue solved. Thanks.

Thanks for the feedback, glad it’s sorted.