Timer Record Not Working

Was the streamed content still playing or had that stopped for some reason?

It’s an old bug that came back in Audacity 2.1.2, but it does not happen on most machines. It is documented at http://bugzilla.audacityteam.org/show_bug.cgi?id=42.

Has this specific machine recorded without this problem before?

If you turn any screen savers off and leave focus on Audacity does it complete the recording?


The input was definitely streaming as the timer function went into freeze after just 11 seconds. The screensaver did not play a part since, as I said, the timer froze after just 11 seconds of recording. This pc (laptop) had successfully run audacity before so its puzzling. Perhaps this is related but the morning when this started, I turned the machine back on after an overnight hibernate and I had to reset pc’s time and date. I’m sure those settings are correct now since I’ve double checked the time and date several times since Audacity started to malfunction. I’ve also tried using the Windows uninstall function and reinstalling Audacity but it seems like the old version is still there as it “knows” my old settings. tnx so much

Do you recall how exactly you reset the time and date?

When you reinstall Audacity, enable the “Reset Preferences” box half way through installation. Otherwise your old settings remain. However I doubt the answer will be as simple as that.


I reset the time and date by clicking the bottom right time which opened the calendar and then clicking time and date settings. From there I manually set the date and time. I’ve subsequently switched back to “automatic” update of time and date in Win 10. I also reinstalled again and wiped out old settings as you suggested but the timer still stops after about 10 seconds (the recording keeps going though). Arggghhh but thanks.

Unfortunately we don’t know why this issue occurs. We can’t reproduce it and its exact symptoms vary from machine to machine.

I don’t imagine it will help, but is your Time Zone correct, and does it match with your Format choice in the “Region” control panel applet? You can get there by Windows key, type “intl.cpl” (without quotes) and hit ENTER on your keyboard.

Otherwise I can only suggest going back to 2.1.1. You can get it here http://gaclrecords.org.uk/legacy/.


I have this exact same issue. This issue occurs every time when there 11 seconds are remaining. I am using WASAPI with Speaker (Loopback). When i use MME, this issue occurs when there are 15 seconds remaining :neutral_face:

Thank you. Please see the previous post https://forum.audacityteam.org/t/timer-record-not-working/43395/7


Hi there, long time Audacity user. What a fantastic program! I hope to be helpful to the community. Read on.

I just upgraded to a new Windows 10 Zotac Zbox, which uses standard Intel graphics, and I’m having the same problem with 2.1.2. Timer record starts, but stops after about 11 seconds. Well, it doesn’t stop, it keeps going, but it is in limbo. The progress stops, but the record appears to keep going. I have to actually kill Audacity from the task manager.

I backed off to 2.1.0, and it works perfectly.

So, I said I want to help. Would a video of the event help? The reason I mention this is because I noticed on 2.1.2, that the timer record dialog box is “fidgety.” It appears to be some sort of UI problem, not really a time problem. Maybe some problem with accessing graphics. I’m just guessing. I program for a living and have seen things like this. I do not see the fidgety, flashing problem on 2.1.0. Only 2.1.2.

Would screen shots or especially a short video help diagnose? Are there debugs I can turn on or any logging? I’m willing to help.

If so, I have one further question: can I install both versions at once? That would be rather handy.


Yes you can, but they need to be installed in separate directories. As a QA tester I have many different releases installed on my W10 laptop (and two on my Mccbook).

You can only run one version at a time though.

I’m puzzled by your Timer Record Problems. I’ve tested Timer Record extensively for the upcoming 2.1.3 and used it for production work a lot an this never happens to me.

We have upgraded Timer record for the upcoming 2.1.3 release. There is a Release Candidate RC2 that can be downlooded from fosshub: https://www.fosshub.com/Audacity-devel.html

Maybe you would like to try the latest Timer Record in this latest RC? If you do anny feedback or bug report would be useful.

If you do, here is the 2.1.3 Timer Record page from the alpha Manual: http://alphamanual.audacityteam.org/man/Timer_Record

And yes you can have RC2 installed as well as your existing version(s).

Finally note that RC3 may be available for testing at the end of next week.


Thanks Peter. I’ll give RC2 or RC3 a try when I have some time, hopefully this weekend, and report back.

If I see the problem, I’ll shoot a 20 second video or so and post it to Youtube to see.

I feel your frustration. I’m usually on the other end of weird issues like this, where a customer insists on something that cannot be created locally!


Thanks but there is no need to bother, unless it is the only way to describe what you mean by “fidgety”. Do you mean that focus on the Timer Record dialogue is coming and going? Some users have said that if you leave the Audacity window on top without task switching away then the problem does not happen, but that isn’t a workaround for others.

We understand the basic symptoms however.

The reason we can’t fix it is that we cannot so far reproduce it on a developer machine. The problem will happen in RC2 or RC3 if it happens to you in 2.1.2. Are you a C++ programmer?


Hi Gale and all. First, I’ve only dabbled in C++, and not with any UI based product. I mostly deal with embedded systems. For this Audacity problem, I’m not afraid to dig deeper if that’s what it takes to help the effort, I’d just need a bit of hand holding.

Before I saw your reply, I shot a video anyway. For what it is worth, the 2 1/2 minutes are here: https://youtu.be/ZceZs0Ll7Nw

Unfortunately, the jittery/fidgity look was not present. I saw it briefly first time, then it went away. I would best describe it as seeing the fonts on the dialog box go jumpy and jittery. It is somewhat subtle, but to me points to a graphics driver issue.

So, yeah, I saw it on RC2. It isn’t intermittent, it is a hard error. The only way I can recover is to use task manager to kill the process.

Here’s a bit of information on my box. It is a new Zotac ZBOX-BI325-U-W2B http://www.staples.com/Zotac-B-Series-Intel-N3160-Quad-Core-32GB-SSD-4GB-Windows-10-Home-Barebone-System/product_IM14T9583. See

Hi there Ray,

just watched your video, most fascinating. :confused:

I tried your settings MME with USB input no automatic Save or Export (and no pre-saved project) - one hour recording, immediate start

a) on RC2 the Timers in the progess dialog alwsays advanced properly - and the Stop worked ok

b) on the latest alpha the Timers in the progess dialog always advanced properly - but on one test occassion, but only once, the Stop would not work nor X-ing the dialog necessitating the use of Task Manger to exit the app. But this is totally unrepeatable for me - and in fact the first time I have even seen it on any of the alphas over the past year sinec we upgraded the Timer Record GUI. So this is decidedly moonphase behavior for me.

I do use the Stop button to halt the progress quite regularly as I often use Timer Record to remember to capture a radio broadcast or webcast. I usually add a 5-10 minute safety buffer so if I’m around I use the Stop once the show has finished. As part of my workflow I always pre-save the project and always check the box for auto saving to the current project at the end of the Timer Recording.

So I’m baffled.


My background idling brain faintly remembered reading about TR issues that folk had around the 10 second mark a while back - so I started experimenting.

On both RC2 and latest alpha on W10 if I Stop the Timer Record in the first seven seconds or so it stops ok.
However if I try stopping in the 10-12 second mark the Stop is ineffectual and Task Manager must be used.

But the countdwn timers always work.

So it looks like I may have bit of reproducability here

Right now I’m testing a longer TR that I will try to stop at the 20-15 minute mark - plus I’ll try some TR tresting on my Macbook

Curiouser and curiouser …



Testing on Mac Sierra 10.12.3 - the progress timers both always work - and the Stop always works.

However with the W10 test when I tried the Stop at 15 minutes into the one hour recording the Stop would not work.

So it’s looking as though on W10 I can reproduce:
a) Timer Record honouring the Stop for the first ten seconds or so
b) but not honouring the Stop once past c. the 10 second mark
c) press the Stop 7 seconds let the recording run on for a further 5 seconds and press the stop confirmation - Stop not honoured
d) the progress timers both always work

I’ll try some more tests with different hosts WDS and WASAPI and non USB inputs and with different settings for automatic Save and automatic Export on completion.

BUT this appears not to be a regression on 2.1.2 - I see the same behavior with 2.1.2 as in a-d here - so it appears that there is something odd happening around the ten second mark and that this has been the case for a while.

However I cannot reproduce this on 2.1.0 or 2.1.1 - for 2.1.2 we did make some changes to Timer Record whereby of you were recording into a pre-saved project then on completion of a Timed Recording Audacity would (silently) resave the project for you. For 2.1.3 we have extended te GUI to make that behaviour clearer and added forther functionality. But it’s looking like we introduced this bug in the transition from 2.1.1 to 2.1.2. - so it is a regression on 2.1.1 and earlier.

It appears on 2.1.2 to be independent of whether or not you pre-save the project - the Stop still fails to act after the ten second mark.

The other odd thing is that when I use the Stop on live projects it is normally on one-hour projects with a five minute buffer at either end and I stop the recording at 65 minutes when the show completes but with 5 minutes of Timere Record outstanding - and the Stop has never failed to be honoured and always has worked.
Can anybody else reproduce this on Windows?


I cannot reproduce this on Windows XP


Just tried on my wife’s W10 laptop with RC2 and cannot reproduce this.

Also tried on her W10 notebook - and on that the progress timers don’t work abd the Stop button does not work.

Still totally reproducible ignoring of Stop after 10 or so seconds on my W10 laptop, happens with all hosts and all availbalble inputs.

So that’s 2 out of our 3 W10 engines that show this erroneous behaviour (and one of those, my work engine, I have not observed it on before today)


I’m in the middle now of a one-hour fifteen minute TR - waiting to try the Stop somehwre near the end

and blow me down with a feather - for the first time ever I’m seeing the progess timers both resloutely stuck on zero :astonished: :unamused:

UPDATE: Well one hour and five minutes into the recording and the Stop doesn’t work, nor does X-ing the progress dialog.

Further update: BUT ARGH - I’ve just looked at the one-hour 15 minute TR that I tried to stop at 14:00 it was scheduled to stop at 14:15 but at 14:31 it is still recording merrily away just like bug #42 ! http://bugzilla.audacityteam.org/show_bug.cgi?id=42
and now cannot be stopped - except by using Task Manager to stop the Audacity process


One additional thing I note is that on my W10 l laptop when the Stop is not honoured to halt the recording, the progress timers remain frozen at the time I clicked on the Stop button.

Not the case for my wife’s W10 notebook as there the progess timers do not wotk at all, ramining stuck on zero.