Timer Record freezes but recording continues

I’m running 2.1.2 (downloaded as .exe) under Windows 10 to digitize LPs, tapes, etc. At times, Timer Record freezes, while recording continues. Clicking Stop in the Timer Record window gets no response. Because Timer Record prevents access to the rest of the program, I have to crash Audacity with Windows Task Manager and re-start it. This can usually be corrected by re-booting the Sony VAIO laptop, but I can’t see a cause. Freezing at 10 sec into a record is common, but I’ve seen 0 (ie. the timer doesn’t start to scroll) and later in a record project. Anyone have any ideas?

I have to ask the basic question: why do you feel the need to use Timer record to capture Tapes and LPs?

I assume so that it’s so you can go away and leeave it unattended while you do something else - but surelylosingaccess to the controls while Timer Record is running is a big sacrifice.

Certainly when I converted my many LPs and Tapes I never used Timer Record - preferring to monitor the recording as it took place (I also have four very active cats!)

Even if you don’t use Timer Record but do walk away and leave Audacity recording what’s the worst that can happen - all you will get is an hour or so of “silence” after the end of the audio - and that “silence” is very easy to delete. This of course presumes that you a) have sufficient disk space and b) don’t go away for the weekend or on holiday with it running.

On the technical issue - I’m somewhat surprised that you find Timer Record freezing. I have used it for many years now several times a week on XP, W7 and latterly W10 and have never encountered that. There are some known problems with the spinner controls that set the recording times so you do have to be careful to ensure what you have set for those. And we did used to have a moonphase bug whereby Audaciy TR carried on recording past it’s pre-set termination date/time, but I have bot experiences this for years now.


Yes, I’d do use the Timer Record for convenience. You refer to the “spinner controls that set the recording times”. Do you mean the small windows in the Timer Record window in which you “dial up” the start time and duration? Please clarify. Thanks for the response.

The bug is still open http://bugzilla.audacityteam.org/show_bug.cgi?id=42 - this is the third apparent report in 2.1.2 since release.

I think the timer is a wxWidgets timer and the update we made to wxWidgets 3 for 2.1.2 could have caused problems on a few machines.

If you (PaulKVan) follow steps 1 to 4 at http://manual.audacityteam.org/o/man/faq_recording_how_to_s.html#timer to manually select when to end recording, does the recording freeze up, and if not does it stop at the correct time?

What is the recording device (make and model number)? Reboots are good for USB recording devices. On Windows 10 a cold boot is recommended (Windows key, Power Menu, SHIFT-click on Shut Down).


Yes. Are you advancing the Start Date to the next day?


Thanks, Gale. The method in the link you posted, ie. using the Add Track function with a segment of the appropriate length, worked fine. I tried the Timer Record method immediately after that, checking to see that the timer windows were tracking the system clock properly and ensuring that today’s date was in the window (I started recording immediately). It froze at 10 sec. I’m now doing another recording per the directions in your link, and it’s working fine. My recording device is an ART USB Phono Plus. Audacity came bundled with it. I hope this helps.

Thanks, Paul. If you set an immediate Timer Record of 5 seconds duration, does it usually stop correctly?


It stops properly after 5 sec. Also after 7 sec. Then it froze at 10 sec.

Thanks for confirming.

Does setting a longer “Audio to buffer” at Edit > Preferences…, Recording tab (such as 4000 milliseconds) make any difference to the issue? Note that Transport > Software Playthrough should be off (not ticked) to test that.


Tried 4000 as suggested, with software play through off, and it stuck at 10 sec. So no luck.

Does the problem happen if you make a Timed Recording from the built-in sound card? For example, a built-in mic if you have one, or a sound playing on your computer?


Sorry, I missed your last posting with the question. I’ve just tried that with internal mic input, and Timer Record continued past the 10 sec point. But (and I told you this was intermittent earlier on), so did Timer Record when it was recording from the USB Phono Plus ADC. I will now start using Timer Record routinely again (I was using the Add Tracks method over the last few weeks). If the problem recurs with the USB interface, I’ll try it with the internal mic and let you know what happens.

Well, Timer Record worked properly for several days, then it didn’t - stopping at 10 sec. Switching from the USB interface to the internal mic produced the same result. I thought at first that this might be related to the fact that the laptop had been awoken from standby, rather than booted from power off as in those previous days, but today Timer Record was still stopping at 10 sec. with both the USB interface and the internal mic, after the laptop had been booted from power off. I’ll stick with the Add Track method, which works well. Let me know if you find a fix (I accept that it might be something in my laptop rather than Audacity). Thanks for the help!

From what others have said, Audacity 2.1.1 or earlier might not have this problem, but that does not help us fix it when we don’t know what it is on the user’s machine that causes the problem.

Does it make any difference if you use a different audio host in Device Toolbar?

Is any application updating or using the system clock while Timer Record is in progress?

Do you have an anti-virus application that is monitoring Audacity behaviour?

None of the above may be relevant. It could be to do with some “state” the machine is in.


I did try the internal mic (I think that’s what you mean as a different audio host) when Timer Record stopped, and Timer Record also stopped after 10 sec of recording from the internal mic. There have been no other programs or apps updating during this time, although I can’t tell what the internal Windows 10 processes are doing vis-a-vis the clock. Norton anti-virus is operating at all times, but I don’t know that it monitors Audacity regularly as the latter isn’t communicating with the Internet. My Sony VAIO does run a range of “VAIO Care” software in the background that is out of date and occasionally unstable. I don’t know whether this might be a factor. I haven’t detected any coincidences.

I meant the first box in Device Toolbar that offers MME, Windows DirectSound or Windows WASAPI.

Norton real-time protection will monitor EXE files by default including Audacity.

If you trust Audacity, it would not hurt to test by adding an exception to Norton for the audacity.exe that you are running.


Thanks for the suggestions. I tried MME, Windows Direct Sound and Windows WASAPI one after the other and Timer Record froze at 10 sec on all of them. I added Audacity to Norton’s Firewall’s Program Control with Allow properties, and still got the same behaviour from Timer Record. I re-booted the computer, in case the Norton change needed that, and no luck. Coincidentally, I have also disabled a bunch of Sony VAIO “VAIO Care” processes that had been running around in the background doing nothing useful, and that didn’t help.

Have you ever tried straight recording instead of Timer Record? Timer Record may be completely beside the point. As Waxy posted up the thread, you can easily record too much and slice off what you don’t need. You could even set the alarm in your SmartPhone. It would be fascinating to find that a straight recording stops at 10 seconds as well.

Since my head tends to get stuck in hardware land: I have resolved problems like this with a memory checker. The checker uses the absolute smallest possible operating footprint and rips through the remaining memory using different data patterns with adorable names. “Walking the Dog Pattern,” “Checkers Pattern,” “Ripple Forward Pattern,” etc. The tester is used in loop. I start it when I go to bed and wake up in the morning to see what happened.

Memory Checker failed at 04:37, Pass 47, “Walzing Matilda Pattern” failed at Memory Location 8845-9932, Bank 5.

Of course, memory is expected to go for years under constant use with zero errors.

But if it doesn’t…

Does Win10 have a drive health tester?



Since this is a laptop, what’s the possibility of heat problems? How old is it and when was the last time you took a good powerful vacuum to the vent holes?

And etc. These are still mechanical devices and can have “magic” mechanical problems.


I expect if PaulKVan tries Audacity 2.1.1, the problem won’t happen. http://www.oldfoss.com/Audacity.html.