Timer freezes but recording continues

Using Windows 10, Audacity 2.1.3, installed with exe installer.

Would love to use the automatic save and export in 2.1.3 but after a few seconds of recording, the timer stops, the recording continues, and I can only exit Audacity with Windows Task Manager.

Have tried all permutations, only using save, only export but it always freezes. Have installed 2.1.3 on another pc and my laptop and get same result. Help would be appreciated.

Sorry, but this is one of our long-standing bugs:
Timer Record carries on recording past the scheduled end, requiring force quit

This is logged as a high-priority P2 bug - but if you look at the bug report you will see that is is classified as “Moonphase”

This means that it is a bug that occurs only very infrequently - none of out QA testers (of whom I a m one) nor any of the developers can reliably reproduce this - and so it has proved impossible to track down.

I’ve been using Timer Record for around ten years now - it happened once for me many years ago - and then again once recently: https://bugzilla.audacityteam.org/show_bug.cgi?id=42#c29

I use Timer Record unattended three times a week every week to timeshift radio shows that are on while I am asleep - so two fails in all that time is a low percentage - but not really good enough. We would love to be able to fix this but unless we can find a machine where this happens with monotonous predictability then we remain stumped on this one.


thanks for the reply Peter. I’m currently using 2.1.1 which works fine on the timer but of course, has no save options. Will keep my eyes open for a fix some time, hopefully.

Hi Mike,

this puzzles me even more then. :confused:

This bug was reported and logged way before the 2.1.1 you are using - in the original report that Gale Andrews logged
he mentions that I had a problem with this in 1.3.11 - so I find it hard to believe that it’s something new from when Mark Young added the Automatic Save and Export (which I use a lot too).

Can you do me a big favour and try Timer Record in the Release Candidate for the upcoming 2.2.0


Will do Peter.

Ah, shame, it did the same as 2.1.3. Downloaded audacity-win-2.2.0-rc1.exe from your link and installed. Set timer for 3 minutes and started audio. After 11 seconds timer stopped, recording continued and Audacity needed a forced quit.

Went to Timer Record and enabled Automatic Save, gave a file name, no other option checked. Set timer for 3 minutes and clicked OK. Did NOT start the audio and timer continued until the 3 minutes expired then saved the (blank) file to .aup. Did the same again but after 1 minute, started the audio and, after 10 seconds, the timer stopped and had to be forced closed.


Hi Mike,

thanks for the testing - much appreciated.

I was this morning reviewing the Release Notes for 2.2.0 ans stumbled across this

Timer Record

Timer Record may not reliably stop the recording on some machines. The Elapsed and Remaining Time counters may stop counting. In this case it will be necessary to force quit Audacity.
On a few affected machines, the problem can be avoided if you leave focus on Audacity or ensure it has focus when recording is due to end.

Maybe you could try testing with and without focus on Audacity while the Timer Recording is taking place.

I normally don’t have focus on it while unattended TR - I minimize the window (I have four active cats who are rubbish at keyboard use) :unamused:



I’ve added your notes to the bug thread on Bugzilla: http://bugzilla.audacityteam.org/show_bug.cgi?id=42#c30

Plus I’ve written to the original developer of Timer Record to see if he can cast any light on this (or even a fix) - but don’t hold your breath.


Started Audacity 2.1.3

  1. Set timer for 3 minutes, enabled Automatic Save and gave it a file name, also enabled Automatic Export and gave it a name. Clicked OK and timer started, focus on Audacity. Focus switched to web page, then opened Word Document for approx 1 minute. Focus back on Audacity and timer still working and counting down. Focus back to web page/s. Timer Recording completed, recording saved, .aup file and data folder, recording exported, .mp3 file created. Of course these saved files were blank as I had not introduced audio.

  2. Same as above but no Automatic Save and no Automatic Export. Focus on and Focus off for at least 1 minute. Timer recording completed the 3 minutes.

  3. Same as 1 above and, after 10 seconds, introduced audio. Timer continued for 9 seconds then stopped. Forced exit of Audacity required.

  4. Same as 2 above and, with audio running clicked OK to start recording. Immediately took focus off Audacity for 1 minute and when focus back recording had stopped after 7 seconds.

When starting Audacity after forced exit Automatic Crash Recovery appeared and if Recover Projects was clicked, recording had been saved up to forced exit, just the timer had stopped and I was unable to stop the recording.

Conclusion as before, Timer runs fine until introduction of Audio.

Hope this is of help to you Peter.


Peter, just bought new (re-furbished) desktop computer running Windows 10, as before, but which has faster chip speed and 8GB ram and Audacity 2.2.2 works fine. Does all the things I’ve wanted. Just thought I’d let you know.

Thanks for the feedback Mike.