Timeline and Waveforms Don't Scroll Together and other annoyances


I just upgraded my ubuntu studio laptop to Ubuntu 19.10 and I have Audacity 2.3.2 installed.

I just recorded some audio and I am now trying to edit the audio. When I scroll through the timeline the timeline moves, but the waveform does not. Previous the Ubuntu upgrade I did not have this situation, both timeline and waveform scrolled together. Is there a setting that locks the scroll of the timeline and the waveform? Or is this a defect or something else that is going on?

Also, when I delete a track the track does not disappear until I resize the Audacity pane (or otherwise force it to refresh) and the audacity window tends to pick up contain background applications or the desktop itself.


How exactly are you doing that?
Normally when you scroll, the audio remains locked to the timeline and both scroll together.

Hi Steve,

In the past I simply could grab the scroll bar at the bottom of the track pane and that would scroll both. In addition, when playing back audio the timeline and waveform would advance together. Now only the timeline advances.

Very strange.

Where did you get Audacity and how did you install it?

It comes with Ubuntu Studio.

Try this, and describe what happens:

  1. Launch Audacity
  2. Generate a 30 second tone (“Generate” menu)
  3. Apply “Fade Out” (“Effect” menu)
  4. Press “Ctrl + 1” twice.
  5. Click the “rewind” button (“|<”)
  6. Click the “fast forward” button (“>|”)
  7. Click the “rewind” button again
  8. Click the “Play” button

Audacity comes up “normally”

After clicking OK on generate-tone the dialog goes away and a blank track appears – no waveform appears in the new track

Fade out – a dialog briefly appears and then disppears

CTR-1 – the timeline zooms in – still no waveform shows

Rewind – Timeline shifts, 0.0 appears, and a grey arrow pointing left is right of the 0.0 mark

FF – Timeline shifts with grey arrow pointing left to the right of the 30.0 second mark

RW – same as before

PLAY – Tone plays with fadeout becoming noticeable between 10 & 15 seconds. Tone plays to 30 seconds with it fading to nothingness (green arrow pointing down moves from left to right)

At no point above do I see a wave form or other sort of information appearing in the track

BONUS: i adjust the Audacity Window size by grabbing the left frame, lo & behold a waveform appears in the track! As expected – the form shows a tone with steadily declining amplitude as it progresses to the right. I zoom in and readjust the window and the waveform updates but on scrolling the waveform does not change.

Funny thing is, I click the X to delete the track and the track appears to remain. However, when I resize Audacity the track disappears. Something is amiss with the UI.

I suppose to keep my project moving (a voice over for a video) I can simply export the audio as is and use Cinelerra to select the portion of the audio I need, but I would really like to trim off the garbage on both ends of the VO.


Very very strange.

Look in “Edit menu > Preferences > Directories”
Where does it say that Audacity’s temp folder is located?

Thanks for the help, I found a newer version of Audacity stashed on my system and that at first glance works as expected.

Consider this issue solved.

It may be helpful for other users if we could establish where these two different versions of Audacity come from, and what the difference is.
Do you have any PPA’s enabled?
If you look in “Help > About Audacity”, what is the version number of the new version that works?