Time Recorder Doesn't Stop Recording at Recording End

Dear all,

For some reason Timer Record doesn’t stop recording at the Recording End time or when I click the stop button prior to the End time. Can somebody help to solve this issue?

This is what happens:

  1. When I hit on the stop button int the Audacity Timer Record Progress Panel, prior to the end time, everything freezes but recording keeps playing. I have to force quit the computer and restart after which I get a message to recover the file.

  2. In the case I let the Timer Record run until the Recording End, in my case after 8 hours, it actually continues to record and the Audacity Timer Record Progress Panel as well and pretends as if the remaining time to record is still almost 8 hours and the recording just started. I have to force quit again and in one case the recovered file showed no sound at all.

Instead of recording for 8 hours I just tested 5 minutes. Both Elapsed en Remaining Time in the Timer Record Progress Panel show 00:00:00. It keeps on recording past the 5 minutes and can’t do anything to stop except to force quit.

Thanks in advance for your help!

Devices/Software Used:

  • Macbook Pro (early 2008) - 177GB free storage - I’m using this old Mac only for Audacity so there are no other applications
  • Presonus USB audiobox
  • Mac OS X 10.7.5 (Not possible to upgrade to later versions)
  • Audacity 2.1.2

Unfortunately the problem is not reproducible on our (or most users’) machines, so it remains unfixed.

The best current recommendation is to downgrade to 2.1.1: http://gaclrecords.org.uk/legacy/.


I have to force quit the computer

Does it work if you Force Quit the application? Apple (upper left) > Force Quit…


If you feeling bold you might want to try one of the latest alphas where the Timer Record setup and other dialogs (the waiting and progress dialogs) have been upgraded and improved.

You can get the alphas from here: http://www.audacity.homerow.net/index.php?dir=mac/&sort=m_time&sort_mode=d

Actually you don;t need to fear using these latest alphas too much, we’re pretty near to an upcoming 2.1.3 release so the alphas have become quite stable, I’m using them as my production versions (I am a QA tester).

If you do download the alpha then this page in the alpha Manual on the upgraded Timer Record may be useful to you: http://alphamanual.audacityteam.org/man/Timer_Record

If you do use the alphas then we’d be very interested to know if you still get the record over-run problem or not (I’ve not experienced this on 2.1.2 or the latest set of alphas on either my PC or my Macbook - and I use Timer Record a lot).

Hint: do make sure that you have set the spinner controls for the recording time and date correctly before you press the OK button in the setup dialog - it’s ever so easy to nudge them and end up specifying a set of times you didn’t intend - don’t ask me how I know :wink:


As I said on the -quality list, at least one other user on Mac has the same issue in the latest 2.1.3-alpha.

That user’s screenshots don’t show anything wrongly set up. UK format time is shown in the progress dialogue when the user’s Mac is set to US format, but you have reproduced that without it affecting Timer Record behaviour.

So I still think this is unsolved.


Thank you very much for your suggestions:

I installed 2.1.1 as Gale advised and the Time Recorder seems to be working normally now.

I also tried 2.1.3-alpha but had the same issues as previously. A 5 minute Time Recording kept on recording passed the 5 minutes. When I clicked Stop it kept on recording and I had to force quit again. “Time passed” was stuck at 6 seconds while in reality it was recording for over 5 minutes already.
I didn’t check if it was set on overdub or software playthrough. I’ll reinstall the alpha version this evening and let you know if this could have been the issue.

Hi - any updates to this issue? I find that the recording does not stop about 25%-50% of the time. Sometimes it simply records for an extra hour or so, but many times it just never stops until I manually stop the recording. I’m using Audacity 2.2.0 (I installed from the DMG) on an iMac running OS 10.7.5

Thanks for any help!

PS - also, the time remaining counter never decrements - it always shows the time that was sent to record.

Sorry no - see this related thread: https://forum.audacityteam.org/t/version-2-1-3-and-2-2-1-hangs-up-on-timer-record/47694/1