there is no noise profile button [SOLVED]


for noise reduction therק is no button to click ok or crקate noise profile - pls see img attached
i had version 2.1.2 and thought that upgrading would help but now with version 2.2.1 - still no button

any idea what to do?


There are known to be serious problems with right-to-left language support. This is largely due to a defect in wxWidgets (the toolkit that the Audacity GUI is built on)

The only workaround at present is to set the language to a left-to-right language. The language setting is in “Edit > Preferences > Interface”.

thanks for generously responding

i went to change it right away but there is no language options - Pls see Img
when i first installed i may have checked hebrew, dont remember
but now with upgrade it was default british English and i did not mess with it
do you think if i uninstall completely and re-install i would get option to choose english?
any other idea?

thank you so much

A suggestion:
The language selection control appears to be missing, but it has been suggested that it is present, but just not visible, and that clicking on the invisible control may make it appear.
Try clicking to the left of where it says “Language”.

well listen
either you are a genius or YOU ARE!
it worked AND i have noise reduction !!
admiring …

:smiley: Ha ha. I was just the messenger. The suggestion came from Paul, one of the developers.
Glad to hear that you are up and running.

I’ll mark this topic as “solved” (although the “right to left” problem is still far from solved, the workaround for changing the language may be useful to others).