Themes don't generate on build

Just to update. I am trying to get image-compiler to work but , at least at my level, it is hideously complicated and I have no idea how to debug it.
I managed to get audacity to build and it actually seems to work, however the UI is dorked up with missing icons as you would expect.

I posted this to discord, but I’m not sure it was the right place so I’m re posting it here .

Hi, I am a hacker that likes to try to build Audacity from time to time. I don’t use conan. I am stuck with in the target “lib-theme-resources”. The "image-compiler " program cannot complete building themes. I ran it with strace and it stops with this last message :

The build stops when executing the target, lib-theme-resources
It looks like it wants to copy to git. Not sure why it’s doing that or how to stop it.

6804 write(3, “/// @file LightThemeAsCeeCode.”…, 35) = 35
6805 write(3, “/// @brief This file was Auto-”…, 44) = 44
6806 write(3, “///\r\n”, 5) = 5
6807 write(3, “/// It is included by Theme.cp”…, 36) = 36
6808 write(3, “/// Only check this into Git i”…, 83) = 83

. . . .
write(3, “96,”, 3) = 3
write(3, “130,”, 4) = 4
brk(0x67e000) = 0x67e000
brk(0x66e000) = 0x66e000
brk(0x65e000) = 0x65e000
brk(0x64e000) = 0x64e000
write(3, “\r\n”, 2) = 2
close(3) = 0
munmap(0x7efffd8f2000, 1105920) = 0
munmap(0x7f000b215000, 368640) = 0
futex(0x7f0019dff678, FUTEX_WAKE_PRIVATE, 2147483647) = 0
futex(0x7f0019dff678, FUTEX_WAKE_PRIVATE, 2147483647) = 0
poll([{fd=3, events=POLLIN}], 1, -1

It seems that the file descriptor is closes and the program then tries to poll it.

When I use gdb basically the same result. Program received signal SIGINT, Interrupt.
0x00007ffff60ff3f4 in GI_poll (fds=0x5c4670, nfds=1, timeout=-1) at …/sysdeps/unix/sysv/linux/poll.c:29
29 return SYSCALL_CANCEL (poll, fds, nfds, timeout);

I am replying to myself. I tried to post to discord . Very fancy but not user friendly to me. I should probably RTF.
Anyway I got audacity 3.4.2 to build with the Themes headers , ClassicThemeAsCeeCode.h DarkThemeAsCeeCode.h HighContrastThemeAsCeeCode.h LightThemeAsCeeCode.h
What was happening is the files were generated but vanished when I CTRL-C when image-compiler gets stuck during the build , trying to poll a closed file descriptor AFAICT. I saved the files and substituted a do-nothing image-compiler executable to allow the build to finish to complete without error-ing out. I don’t know if anyone followed this at all. I am using glib-2.78.1 and gtk+ 3.24.37 and the audacity wxwidgets git. I am hoping to try the VST3 functionality.

This topic was automatically closed after 30 days. New replies are no longer allowed.