The equalizer crashes Audacity

Hello, people of the internet.

For clarification, i am using Windows 7 Family Edition Premium,
and my Audacity version is 2.2.2.

So, i wanted to equalize a bit of sound to make it sound better so i go in effects, then i click “Equalization”, and then… Audacity makes a debug report ? :confused: which probably means that IT has crashed.
The thing is, the crash only occurs… on one specific project. What do i do ? :neutral_face:
I can provide the project and/or the debug report.

The project would be useful (including the data). How big is it? Can you upload to dropbox or similar?

I suspect there is some corrupt data in the project (could be just one bad sample value).

Here is a .rar file of the .aup file and its “_data” folder:

Also, the “_data” folder is…229 MB :blush:

It’s not crashing for me.

What exactly are you doing? (which clips / tracks are you selecting? Are you using presets? Graphic mode or Draw mode? When exactly does it crash?)
Talk me through, step by step, how to reproduce the crash.

It’s quite simple.
I click on “Equalization” and it crashes when normally the editor window would pop up.
I have attached a video recording of me doing the crash instructions to this reply.
If the video isn’t attached, use this link

Unfortunately I can’t use that link because it appear to not be “public”.

Well this link has to work.
But i don’t think sharing a video does much.

Yes, that works. I can see that Equalization is crashing as soon as it opens.
I’m surprised that this is only happening with one project. Are you certain that Equalization is still working on other projects?

We may need someone to test your project on Windows (I’m on Linux) and see if they can reproduce the problem.

I recorded myself in a blank project and used “Equalization” and it works perfectly.
I also opened up an old project and used the effect and it worked there too.

Well step right up, ladies and gentlemen. Looks like we need a volunteer from the audience !

Not from “the audience” but a QA bod …

Steve provided me with a copy of your project (thanks for that Steve)

Running this project on 2.2.2 latest release . and the latest alpha build I have for the upcoming 2.3.0 - I do not get a crash.

But after selecting the entire project and trying to apply the EQ effect I do get the error message: “To apply Equalization all tracks must have the same sample rate”

You have mixed sample rates in your project:
Mono 22050
Stereo 44100
Stereo 96000
Stereo 44100
Stereo 44100


But how about selecting only one snippet of audio on one track ?
Does it work for you ?

Edit: oh it doesn’t ? i see.
I can understand the sample rate problem, but for the single tracks i don’t know.
I’m deinstalling Audacity and reinstalling it.

Guys ? I just resampled all the tracks and now… It works ?
(i also removed two useless tracks cough)

I was about to suggest that, but it remains a mystery why it was crashing before. The multiple sample rates should just produce the warning that waxcylinder reported, not crash.

If you see the problem again, please do let us know. The crash issue, whatever the cause, may be fixed in the current development code, but if there is a bug lurking in there, we really need to know about it so that it can be fixed.

Yes, it remains a mystery.
But actually…

The last time i opened it (to resample everything), i selected two entire tracks with differing sample rates and clicked “Equalization”.
And it didn’t crash, but waxcylinder’s warning popped up. That means the problem was something else.
And i know it wasn’t because i reinstalled Audacity, because it still crashed on selecting and (attempting the process of) equalizing one single track.
(remember, i still hadn’t resampled the whole thing at the time.)

But yeah. Problem solved. I will come back if i have any other problems, inquiries or the second coming of this bug :laughing:
And i hope to see what 2.3.0 brings to the table :slight_smile:
Thank you steve, Thank you waxcylinder.

I found this thread because I too had this problem and just wanted to add my issue in case it is, in fact, a bug. I am on a Mac though so forgive me if this is unhelpful since this is the Windows forum.

Audacity: 2.2.2
Mac OS: High Sierra 10.13.4

Steps to produce issue:

  • Imported a 32kbps mp3 file into Audacity
  • Stereo to mono
  • Added a new mono track
  • Split the first track and moved part to the new empty track
  • Effects > Equalization > Debug Report + Crash (Repeat this step several times before checking Google)
  • Saw this thread and recognized that the initial track was 16000Hz and the new track was 44100Hz
  • Saved each track as a 32-bit wav file
  • Created a new Audacity project and imported both newly created wav files
  • Happily equalizing to my heart’s content

I can’t reproduce this following your steps - I can only presume that you somehow had mixed sample rates (not sure how from you steps decription)

That’s because each track will now have the same sample rate, the project rate you have set in the bottom left corner of the Audacity window.

But glad you got it working :slight_smile:


Yes simple fix for me this one, as previous poster said, just ‘resample’. Select all, go to ‘Tracks’ menu and click ‘Resample’.

Pretty worrying the way it crashes your project at the time though and one hopefully for the Audacity Team to take a look at?

The current version of Audacity is 2.4.1. In this version, the Equalization effect has been replaced by two new effects:
Graphic EQ:
Filter Curve EQ:

Audacity 2.4.1 is available via the Audacity website:
(Audacity 2.4.2 is due to be released soon, and the Audacity will be updated accordingly)