Taking way too long to import

Hey guys! I’ve recently downloaded Audacity and I tried to import a 27min mp3 file but it is taking way too long. I’ve been waiting for 34 minutes and it says remaining time is 8 hours and it is still rapidly counting up. I have no idea what i’m doing wrong. Another file that I tried importing was 4 minutes and only took like 3 seconds to import. The 4 minute file was a song and the 27min file was someone talking. Please help me out!

Also, I am using windows 10 and Audacity 2.3.3
Annotation 2020-01-16 000641.png

Is it just that one file that’s causing the problem?
Try importing other files of about the same duration and see if they have the same problem.

Testing on my W10 laptop (SSD)

I created a 27 minute 256 MP3 stereo file - export took 37 seconds.

Import took 7 seconds on both 2.3.3 and the latest test alpha build I have for 2.4.0


import a 27min mp3 file

Since Audacity doesn’t edit MP3, what that really means is Audacity is converting your MP3 to its own very high quality internal format and opening that. So depending on the compression of the MP3, the actual file may be very much larger than you think it should be and there’s a lot of work going on behind the scenes. Do you have room for all that work?

Depending on where Audacity is opening the work, either Windows security or your virus software may be trying to carefully inspect each piece as it goes.

How do you know it’s an MP3? Did somebody send you an MP3? You can find out what it really is.