suddenly unable to save files [SOLVED]

I’m running cinnamon.
I have recently updated to audacity 2.1.3.
I have no trouble saving edits to files that were recorded on an older version of audacity, but I seem unable to save a file that I recorded today.
I have a deadline and am really stressing it.

Any help would be amazing!

potentially relevant information:
I had to change ownership of the plug-ins file in order to add a .ny
I have since changed the ownership back to root but it seems not to have impacted my problem.

Audacity 2.1.3 does not exist yet. It has not been released. Our development code is 2.1.3-alpha.

Where and how did you obtain Audacity and what version number exactly does Help > About Audacity… say?

You don’t have to change ownership of a folder to add a plug-in, nor do you have to add Nyquist plugins to a system folder. It is recommended you do not add Nyquist plugins to system folders, because updating Audacity installation could delete those new plugins.

Create a folder .audacity-files/plug-ins or .audacity-files/plugins in your home folder (note the dot at the start of the name) and place your Nyquist files there. See

If you must use system folders, use a sudo mv command in the terminal to move the file into the system folder. Then you won’t change ownership of any folders.

Are you running Audacity as root? If so, save or export to a folder that root owns. If you are running Audacity as you, save or export to a folder that you own.

if that does not help, tell us the error message in full and tell us whether you are exporting or saving, exactly where you are exporting or saving to, and the exact file name you are saving to.


Hey Gale,

When I pull up About Audacity from the help section, I am shown | Audacity 2.1.3-alpha-Sep 7 2016
I initially downloaded from the terminal, but in my efforts to troubleshoot have many times deleted and downloaded Audacity, both from the terminal and from the Software Manager.

I was unaware that there was a way to add nyquist prompts without adding it to the plug-in folder, which was owned by root. I changed the ownership of the file, added the prompt, and have been able to edit and save previous .AUP files.

This morning when I recorded a new file (the first that I have actually recorded with this new version of audacity) and found that I was unable to save it, I changed the ownership of plug-ins back to root. This has not solved my problem, unfortunately.

I am able to export the file as an mp3, which is a fine temporary solution. And each time I close audacity I am able to recover the unsaved file. This is obviosuly not ideal.

There is no error message when I try to save. I am able to type in a file name, choose a destination, and when I click save audacity closes, creates an empty data folder, and nothing else.

Alpha builds are unstable by definition. If you need Audacity for your living, stay with release builds.

Are you using the so-called “Audacity Team” daily builds from - or did you build Audacity yourself?

You can type Nyquist Prompt script lines directly in Effect > Nyquist Prompt… .

No files or folders in your home folder should be owned by root, they should be owned by you.

Now you have said exactly what the problem is, it’s a bug if 2.1.3-alpha is compiled with gcc 4.8 or earlier. If you built Audacity yourself you can correct it by following

If you are using some ready-built package of Audacity, you have two options.

One is to uninstall the 2.1.3-alpha package and reinstall the version of Audacity that comes with your distribution.

The other option is to uninstall the 2.1.3-alpha package and install the latest “Ubuntu Handbook” 2.1.2 Release PPA from This will not have the crash problem on save.

Install the 2.1.2 PPA version that corresponds to the base Ubuntu version (“Compatible repository”) in this table: .


So, I had assumed that my problem may be that I was working with an unstable audacity, however through some form of ignorance on my part I seem to be unable to download 2.1.2, or for that matter any stable version of audacity.

I have only downloaded the ppa from the link you have provided, yet the audacity that installs is 2.1.3. I have tried this multiple times with the same result. Even after completely purging audacity.

I have also tried downloading it from the software manager and have again been vested with 2.1.3.

I am running Rosa, which should work fine with audacity.

i’m just completely perplexed.

Assuming you have the so-called “Audacity Team” PPA:

sudo apt-get install ppa-purge

sudo ppa-purge ppa:audacity-team/daily


the ppa purge worked like a charm. and i am now running 2.1.2
obviously at some point i sourced from audacity team and had henceforth failed to purge the ppa.
thank you for working through my ignorance with me! (i’m new to ubuntu)

I’m glad you got back to a stable version of Audacity :wink: . You might have added other sources to your software sources. If you do that you usually get the unstable alpha builds of Audacity, and that is all “Ubuntu Software Centre” will offer you unless you dig deeper through it.