sudden appearance of recording latency

I have had no latency at all with Audacity 2.0 until today. I have been using it extensively for months now with success. Now, suddenly, latency shows up when overdubbing. I’ve read the manuals with no progress. Any suggestions? Thank you. I have Windows 7 and I think it was installed with .exe installer.
Thank you,
Michael Julian

Which latency changed? There are two. Recording Latency is the one where you sing in perfect time and rhythm but the recording is off. The other is you sing and your own voice comes back to you echoey and late.


The type of latency is the delayed echo from the mic before and during the recording.

So did you change to Windows 7 when this first happened? It’s rare for Windows 7 to provide hardware playthrough.

If you had no playthrough latency and this mic is connected to the mic port of the computer, then you must have had the mic unmuted in the Playback side of “Sound” in the Windows Control Panel. You will need to go back there, select Playback tab, right-click over the mic > Properties, choose “Levels” tab, make sure the mic is unmuted, then turn off Transport > Software Playthrough in Audacity.

If that does not help, exactly how does this mic connect to the computer?


Thanks Gale,
The computer has always been with Windows 7 with no change in this respect. Also I am using a Shure SM58 with a Shure X2u USB adapter. I tried what you suggested and still have the playthrough latency, but shorter in separation from the live vocal signal.

You have one of the certified chains of equipment that allow you to do perfect, no compromise overdubbing/sound-on-sound.

The trick is you can not monitor sound from the computer, it is required you listen to the X2U. It will do the sound management for you.®_X2U_Microphone_Amplifier-USB_Adapter

Scroll down to the connection illustration. Chances of making this work any other way are slim. The delay through the computer USB management and sound card will not go away.