Successive Recorded Tracks Coming out of Alignment

I mostly use Audacity to record vinyl records and export the sound from them, and I’ve noticed a minor bug in the last few versions of Audacity: the second recorded track, if started where the first one ends, comes out of alignment with the first one by the time I finish recording it. Is anyone else having this problem or one similar to it? I’m using Audacity 2.1.1 with OS X 10.10.5 on an iMac from mid-2007.

I read that five times and I still can’t figure out what’s coming out of alignment with what. Try again. Use different words.

Koz

The second track comes out of alignment with the first one by the time I finish recording the second one.

That’s using the same words.

What’s the goal? What are you trying to do? If you want to create a seamless mix, you can use the Time Shift Tool to push selected segments sooner or later on the timeline.

http://manual.audacityteam.org/o/man/tools_toolbar.html

If you need overlap, then record on separate tracks, time shift tool your way to alignment and then Audacity will make one simple track on Export.

Koz

Let’s say I’ve already recorded one track and I start recording another one where the first one ends. By the time I finish recording the second one, it moves slightly back in the recording so that it starts before the first one ends. Maybe I wasn’t using the word ‘alignment’ precisely enough; I’m just trying to record successive tracks without having to align them end-to-end every time a track finishes recording.

Maybe I wasn’t using the word ‘alignment’ precisely enough

No. Not enough detail. We have to build your system in our imagination to see what you’re doing.

You get to the end of the first segment, Pause with the “P” key and P again to start the second segment?
You get to the end of the first segment, Stop, and then use Append Record (Shift-R) to pick it up again?
You get to the end of the first segment, Stop, place the cursor at the end of the first segment and then press Record?

All of those techniques will give you one-after-the-other recordings, or versions of that in Audacity 2.1.0 and later.

Koz

Turn off Transport > Overdub, if you want to record into separate Audacity tracks. Then the subsequent tracks won’t be shifted backwards by the “Latency correction” setting in Recording Preferences.

The latency correction is for people who layer tracks one above the other so they play together, such as a drum track with a vocal underneath it.

Or hold SHIFT and click Record. This records at the end of the selected track(s). The newly recorded clip will then not shift backwards even if Overdub is on.


Gale

I turned Overdub off and it worked, but then I followed the link you gave me, and I decided to turn Overdub back on and just set Latency Correction to 0; that way I can still overdub if I want to.

I can still overdub if I want to.

Yes, but it may not match.

The purpose of the Recording Latency setting is to eliminate the timing differences, to make sure what you’re recording syncs with the original track. It makes the playback and record management system delays vanish. Unless you got super lucky, a setting of zero latency is going to mean your new track isn’t going to match your old one.

This is what happens when I hold my headphones next to the microphone and play a click track.

The difference is the Recording Latency for my machine.




Tune the latency out and new and old tracks match.

Koz

Ah alright. I guess I’ll put it back to 130 if I ever do want to overdub.

130 if I ever do want to overdub.

If you want to overdub you have to set it for your machine and sound system combo. 130 is a wild guess. Chances of it working in your machine is zero.

The instructions for setting Recording Latency / Overdubbing.

http://manual.audacityteam.org/o/man/tutorial_recording_multi_track_overdubs.html

Much better to set it for your sound system and microphone and select/de-select Overdub as it’s needed.

Koz

Alright, thank you.