"Stuttering" Glitch

Hi I’m running Mountain Lion. I suspect that this is not a fault with Audacity but thought I’d run it by…

Occasionally I have a glitch on recordings that sound like a stuttering repetition of a segment of recorded audio. This has actually been recorded as such and is not just on playback.

I am using either a focusrite saffire audio interface with phantom power for this or a usb / xlr converter which also provide phantom power.

Many Thanks,

Did you get to Mt Lion by continuously upgrading one computer, or is this a new machine? Is the USB audio system a home run, or are you going through a USB hub? How full is the machine? Are you doing many different tasks a the same time as the capture? How many things have positive markers under them on the task bar.

Post one of the glitches so we can hear it.


What’s the average repetition rate? About once a week, once every couple of minutes?


Thanks for the promt reply. This is a new MacBook and I upgraded ro Mt Lion not long after buying it. There’s no SB hub involved just the audio interface or XLR / USB converter / preamp.

There are ± 6 apps with markets beneath them when recording. The average repetition rate is about once or twice a week.

Please find attached an example.


I can’t explain that one. In each case the first instance of the word has a trailing segment where the digital process goes insane – then it repeats the word – correctly. Since I got nothin’, I would do a simple drive test.

Go > Utilities > Disk Utilities > select your system drive and > Verify Disk.

It might also be worth doing a memory test. This is a little rough on a Mac, but it can be done.


Audacity uses memory a little oddly compared do some other programs, so if you have bad or ratty memory way up in high memory somewhere, Audacity may not need it except under some digitally stressful circumstances and then create damage in the sound. But only every so often.

I think there are ways to read the logs and see if they turn up anything. I’m a little fuzzier on that.


Hi The HD needed a minor repair. The RAM tested fine.

I guess I could close some non-essential apps before recording.


Live recording is stressful for the machine. That and video production are responsible for trashing more computers than anything short of fire or earthquake. When you do a gaussuan blur in Photoshop, the machine just sits there cranking until it gets done. It can’t do that will live sound. If it’s not done with this note, it’s going to miss the next one.


The jury is still out, by the way. You don’t have speed problems. They usually show up as gritty sound or holes in the show. That’s not what you have.

We’ll see.


OK, thanks. I would try testing a different platform, but I Audacity is the best all round app for the work I do. :slight_smile:

Do try that.

I have today encountered another “glitch” (attached). No mic signal recorded, it seems - just this constant “ticking” effect.


I have the same problem as OP’s first up loaded sound file.

Audacity August 21, 2012

MBP / 2.2 GHz Intel I7/4GB RAM 1333 Mhz DDR3/ OS 10.8.2

Saffire 6 USB [MAC OS Boot HD] & Digi 003 [Boot camp running XP & PT]

Have already done a disk repair, and repaired disk permissions, memory is fine and still have the same problem as OP.

I run Ableton Live 8, Reason, on the OSX side and have run PT on the XP side all running and recording fine. I would like to use Audacity on the OSX side as it’s a straight forward sound editing tool, and I do not have to boot up in XP/boot camp to run PT when I want to digitize my 12" wax. I have also tried recording with and without the
Software/playthrough & Hardware/playthrough active and not active with a no go still getting the repeat audio recorded. I have also played with the audio to buffer at 50ms, 100ms, 150ms, 200ms, and this has not helped as well.

Saffire 6 Audio interface is direct into USB port on the CPU using the internal drive as the temp directory with free space of 177.4 GB, after recording I dump to external drive.
The repeat audio can happen anywhere from 30sec, 2min, into the first song of a LP and not happen again until the third song on the LP and again it could be 30sec, 1min, etc into the song that the repeat audio is recored. I have also tried just to do one track at a time and the same thing happens I may get one song to record fine then the next one will stutter/glitch.

So if anyone is/had this problem and found a fix or is still working on a fix, what thoughts may you have on this problem?

Thanks in advance,