Stutter-click at start of song recordings


I’m recording a playlist of processed songs but each time the recording starts after a gap of silence there is a brief stutter-click. In the finished recording each song has that split second interruption at the beginning.

I tried switch off sound activated recording but I still get that issue.

is there a way to resolve this?

More information please.

Audacity version; macOS version; computer; what you are recording; how the connection is made.

– Bill

Thanks so much for getting back to me.

I’m running the latest version of Audacity and Mac OS (10.14) on a MacBook Pro 15”.

I’m playing songs in an audio hijack chain starting with Audirvana going through various processing into IShowU as a virtual output. I’m recording the IShowU stream as an input into Audacity and outputting to my DAC as a monitor. I’m upsampling once at the start and then keeping the bit depth and sample rate consistent.

It all works beautifully. The one issue is that after the gap of silence between songs as soon as the wave form starts there is a “hiccup.” Sometimes it’s a slight interruption or a small click.

Any ideas?

I hope not. The “latest version” is “2.3.1 alpha” and is intended for development and testing only.
Look in “Audacity menu > About Audacity” for the actual version number.

Yes, right, I’m running the latest official version 2.3.0.

Can you monitor the audio at other places in the stream, such as the output of audio hijack, the output of the processing, or the output of iShowU?
– Bill

Yes, definitely. The click only happens when I’m recording on Audacity. When I record the output within Audio Hijack there are not issues. However, I need to record the audio after it goes through the output mixer (Darin Fong’s OOYH).

Also, I just recently discovered Audacity after hearing about it for a long time. It is marvelous at what it does and just a pleasure to use. It is this one issue that is tripping it up for me.

And when you listen to the output of OOYH there is no click? Also when Audacity is in monitoring mode (click on record meters but don’t start recording) is there a click?

The only thing I can think of at the moment is to try adjusting the Buffer Length in Devices Preferences. Start by reducing it, to as low as 20 msec, then test.

– Bill