Strange problems with Audacity

I have a strange set of problems with Audacity: version 2.0.4 running (or not running) on Windows 7.

It was fine. Then onetime when I tried to start it it apparently wouldn’t start. However when I looked in Task Manager the process audacity.exe was running. But it wouldn’t stop when I tried to stop it. I uninstalled Audacity using Control Panel, though it wouldn’t fully uninstall and the process remained active in Task manager. I did a scan but found no issues. I tried to reinstall it and got various messages about problems which I won’t try to list. I tried to manually remove audacity.exe but the computer told me the process was in use in a version of Audacity already running.

The only way to stop the process audacity.exe was/is to switch off the computer (and I think disconnect it from the mains). I did this and then uninstalled or manually removed all the relevant files that I could see (couldn’t think of anything else to do being ignorant) including audacity.exe and the Audacity folder. Then I reinstalled it from using audacity-win-2.0.4.exe. Everything went fine. But (you’ve guessed it) Audacity wouldn’t start and the same cycle of problems and messages started again. I went through this process a couple of times. I did notice that in Task Manager the installer seemed to be running twice…eventually I removed one but it didn’t seem to help in the end.

So somehow I seem to always end up with an invisible version of Audacity running. I realise that this problem has probably nothing specifically to do with Audacity but is a confusion in the machine, but any suggestions would be gratefully received! It’s not life threatening (I hope) but I like Audacity.

I should perhaps add that having read the message at the head of the forum about problems with version 2.0.4 I tried installing 2.0.3 but I have more or less the same set of issues, and the programme while starting in Task Manager will still not start on the screen.

Restart the computer again so that Audacity is not running.

Re-install 2.0.3, making sure that “Reset Preferences” is ticked (checked) half way through the installation process. When Audacity starts, confirm you want to reset preferences.

If it is a machine confusion, it is probably a security program or a bad audio driver causing the problem. It could also be a bad VST plug-in. Did you add a plug-in or a security program just before the problem started?