Strange error when exporting (MP3 and WAV) [SOLVED]

I’m not so good with figuring out things like these and I really have no idea why its happening but when I go to export the Aup file to an MP3 or WAV I get this error whenever I try to export.

It takes me to the regular prompts to export if I click okay however, it comes out as a ‘blank’ or unreadable file.

I’m running Windows 7 64 Bit with Intel core i3-2338M CPU @ 2.20 ghz and 4 gig of ram. The version of Audacity is Audacity-win 2.0.5 and I obtained the installer. I’ve tried reinstalling Audacity but the issue continuously occurs. I also have the extension LAME for Audacity to export MP3 files. I haven’t had any issues with like this with Audacity before so I’m really confused as to why this is happening. Any help will be appreciated as I would like to see whats going on.

It’s because of the dots “.” in the file name.

File names are made up of two parts: the “name” and the “extension”. By default Windows will hide the “extension” part of the name.
Typically an MP3 file will be called something like “mymusic.mp3” where “mp3” is the file extension.
Between the file name and the extension is a dot.

If you use a dot in the file name then Audacity thinks that you want the letters after the dot to be the file extension. If this is not a standard file extension Audacity will warn you.

It is possible to use dots in a file name, but if you do so then you must manually include the correct file extension in the name.
Generally it is better to just avoid using dots in file names, then Audacity will automatically add the correct file extension.

See here for more information:

Ah that’s more obvious now. I should of realized when taking a look at the file type it ‘exported’ as. Thank you for your help.