Strange audio problem

I recorded some audio which was fine for most of the recording, but suddenly started to make clicks, which then develops into what seems like audio being clipped from half a second before and moved forward. This worsens gradually and then disappears before the end of the recording. Attached is what it sounds like at its worst. This lasted about 20 mins. I’m not sure if it was Audacity (2.1.1), my Mac (10.11.1), or the CAD U37 USB condenser mic I was using. Any ideas of what this problem is and if/how I can fix it?


I had that happen with an older Audacity. If you listen carefully, it’s splitting the sound up into tiny chunks and then delaying one set of chunks, such as every other. You can hear the same same words words twice twice as it bubbles.

I don’t know that we ever solved it. I restarted my machine and it hasn’t done that since. That show is trash. My show was a transcription, so I was able to play it back multiple times to copy all the words out.


Unfortunately I can’t re-record this. It really makes me question my faith in Audacity to record reliably. Does anyone know of a way I can recover it?

If you can, turn off WiFi.

Open Audacity > Preferences… , Recording section, set “Audio to Buffer” to zero, try to record, if it does not record, set it to 10 milliseconds, then so on upwards in 10 millisecond increments until it does record.


I can record, it recorded fine for over an hour before this problem gradually occurred. I’m asking now if there is any way to recover the data, and if there is any way to prevent it happening in future or if it is a bug in the software.

The data thinks everything is just fine. The show is trash.

It’s not a bug. A bug is a very specific thing. This appears to be a Mac oddity. Once every three or four years. Restart the Mac and it should be ok. I had not restarted in a very long time. The Mac that did this is not on WiFi.


It did not record fine due to the length you recorded for. USB devices cannot be necessarily be relied on to to record for hours on end.

The idea of the audio to buffer experiment is to set the value to the lowest level that you can safely record at, to hopefully make the problem much less likely to happen again. Also try the WiFi suggestion if you can (if it is relevant). That pair of suggestions have worked for others. Restarting the computer before an important recording might help too.



Do you have an SSD Solid State Drive? Something somebody said a while ago rang a bell. Some SSDs take steps to prevent the drive from repeatedly beating up one small portion of the memory. They do this by “wandering,” changing the addressing scheme very slightly over time to add “noise” to the scheme. Tell me this doesn’t sound like what you have: a tiny portion of the performance isn’t where the system is expecting it to be and it gets slowly worse over time. Then it wanders back.

It’s not likely to be a “normal” error. USB errors don’t neatly duplicate words one after the other. Most digital errors produce un-ordered garbage, holes or sounds unrelated to the show. And they never fix themselves.

The show is still trash. You can’t even write a program to rescue it due to the wandering nature of the error. It would be a career move.

Restart the machine. Cold start. Do that at the beginning of each serious recording session.


Can you find that posting where I complained about the same error?
If I have a date, I can locate the sound clip, a WAV, that will provide second, good quality evidence of the error.

The problem is with your USB mic or even the USB cable/port.

It’s a clock problem. Audio and video need to be timed precisely. To do that, a clock signal is generated by the AD chip in the mic. USB doesn’t know about a clock, it just knows about data. And when you send data to a disk, or to a printer, there’s no need for a clock. It doesn’t matter if the data arrives on time. For AV, the clock is mixed in with the data.

When using USB for audio, the clock needs to be “extracted” from the data. Simple enough, except when the clock in AD chip starts to drift. And that’s what you’re hearing.

The mic has warmed up. The clock drifted. And your computer lost track. When there’s no clock, it stops. And restarts, but with old data and a new clock.

Some computers are more sensitive than others. If your USB port is loose, dirty or the cable is so-so, more packets will need to be retransmitted. And that’s when the clock regeneration can’t follow.

A stupid way to avoid this, is powering the mic at least an hour before recording. Put a towel over it. Studio’s keep all their gear at constant temperature. Well, at least big professional studio’s. I also know some that go dead cold at night. They have far more noise and gear problems, also because of condensation. :unamused:

In the modern digital world, there seem to be no limits. It seems all so easy, because you can’t see the limits. If you need to record long takes, you need to test. Try a better/shorter cable, fi.

Filesize is another limit. When recording at 24/96, you eat up a lot of disk space. WAV has a filesize limit of 2 or 4 GB. Audacity has an internal limit. And so on. It’s a long, but fairly interesting journey. :wink:

I don’t know that I’ve ever heard a USB recording error produce two shows in the same playback. This isn’t a normal damaged USB error. People are not lining up complaining about this effect. Ticking, yes, holes and gaps, certainly, noise, yes, dropping out completely, sure. Speed and sync problems, every day, but recording two distinct performances a fraction of a second between them is not high on the hit parade.

I’m also betting the poster never has this happen again. I haven’t. I didn’t change any hardware, environment or conditions, and I don’t have any other USB errors or indications of instability. I’ve been doing this a long time; it was a very nasty surprise.

Locust Cycle Error.


If we haven’t scared him off, I’d be interested if he monitors the computer playthrough, even with the echo just to be sure the computer is getting the show OK. If it’s a USB error, playthrough would be trash.


I agree the sound clip is not a normal USB error, but it started exactly like the “clicky-USB-recording-due-to-buffer-setting-or-Wi-Fi” error that begins after 30 minutes or an hour (which usually looks like dropouts).

I figured if we could stop the problem starting, it might not morph into what we have in the sound clip.


It does, but it’s now many lifetimes, not 13.5 hours at 44100 Hz, 6.75 hours at 88200 Hz and so on as it used to be.


Here, but only Forum Staff / Crew can see it

I notice that started as “just ticking” then morphed into overlaid pieces.

The final clip is here: .


I posted it on my own web page [red face].

Given those clues I found the original WAV recording. It’s 37-1/2 minutes and it’s a telephone recording with a representative of an investment company, so I won’t be posting the whole thing. It’s required reading because she gave me step by step detailed information how to manage my account. I wasn’t writing it down. Account numbers, passwords, and identity information will remain our secret.

There is a segment where she said “ahhhhhh” in the chop and I can give exact chunk and fragment information by ripping apart the waveforms. It’s much more complex than I thought. My effect did not vanish by the end of the show, but I think it’s only a matter of time. The distortion was getting less severe as the performance progressed.

It doesn’t alternate between simple fragments: 1, 2, 1, 2, 1, 2. The “Ahh” word is recorded as fragments 2, 4, 6, 1, 3, 5, 7. So the lead or attack of the word isn’t actually recorded until the fourth fragment.

Twilight zone moment.

I’m looking forward to telling my grandkids: “You kids have it soft. In my day we had to wrap our microphone in towels and warm their feet to get a good recording.”


Sorry I disappeared. I’m not sure what you mean here by playthrough?

Thinking about the environment the temperature of the mic did change quite a bit from cold to warm during recording.

I also had WiFi on, and I’m on an SSD macbook pro. I’ve got plenty of disk free (12GB) and RAM (16GB). I recorded for about an hour problem free, the problem came and disappeared gradually over ~25 minutes. After that it was fine. It might be that the offset audio increased in duration until it overtook the original one…i.e the samples at time offsets A and B go something like AAAAAAAAAABAAAABBAAABBBAABBBBABBBBBBBBBB, but it’s hard to tell.

Oh and the cable is not very long with gold connectors, although connected to a well used USB port.

If you turn on Transport > Software Playthrough in the Audacity menu bar, then you will hear while you are recording and could tell if it was “overlaid pieces”.

With a rare, not understood problem we can’t guarantee it won’t happen again. But it is “possible” that turning off WiFi and setting Audio to buffer as low as you can will help. Please try both.