Strange: Applying effect removes waveform


Audacity 2.1.2, straight download. Windows 10.

New user, trying to learn, but have come up against an interesting problem. Sure I must be doing something wrong/have something set up bad but I’m flummoxed as to what it might be…

I have a vocal track that I want to add some reverb to saved as an audacity project. I select the track by clicking on the “44000” bit in the left hand box. I go to the effects menu and select reverb. Leave the defaults in the popup box alone and apply. I get a popup that takes about 20 seconds to finish. But what it does is completely flatten the waveform to a line, i.e. loses everything.

Anyone any ideas what I might be doing wrong?


Did you look in Help > Show Log… and see errors about being unable to read data files?

What happens if you do choose Factory Presets > Defaults in the Manage menu?


Thanks Gale,

Yep, did the factory defaults thing to no avail. Will check the log - the existence of which is the first thing I’ve learned today!



OK, so the log gave me some clues!

I’m editing across a network (i.e. got a copy of Audacity on my laptop that I’m using for recording and trying to edit the files from my main PC. Laptop is saving files onto C:\ and Audacity is installed on C:, whereas the PC it is installed on D:\ and would be saving (although not tried to save it yet) to D:\

Guessing it doesn’t like that much from the errors I’m getting.

Will try and edit on the laptop and see how that works.


Can edit fine if I copy the files across to the main PC. So the question is, I guess…

…with a copy installed on D: on the laptop, a copy installed on C: on the PC, and a networked connection am I on a hiding to nothing trying to edit/add effects to laptop recordings from the PC?


Audacity doesn’t understand network connections, delays and switching. It works best if all the work, files and program are on one machine. You may be able to force it to work temporarily, but when the network changes because of load or speed variations, it could fail again.

It’s a particular problem if you’re doing time critical work like overdubbing and sound-on-sound. You would never get the latency settings stable.


Yep, I get that - wouldn’t try and actually record anything via network.

But when the files already exist isn’t it just file manipulation? Load file(s) into memory, make changes, store back on disk? Or am I not understanding what’s actually happening?


What format are the files in? If they are WAV, I am guessing you may have better success if you chose the option to make a copy of the files, which would then get the data onto the main PC drive D:, assuming your Audacity temporary directory is on D:.

You may need several attempts. Look at the Log and don’t proceed with edit until you get an error free import.

Or have you already changed the Audacity temporary directory for the main PC to C:? You can change the Audacity temporary directory in Directories Preferences.


I have had the same happen sometimes under other XP with 2Gb RAM and other effects. Restarting the PC fixed it. I would have thought you’ve done that already, so how much RAM are you packing?

Would a task killer such as enditall help or a RAM disc help?

Try a reverb plugin from You will need to follow the install instructions.

Try also using the latest nightly build. Link is in a thread higher up this board.

Being short of RAM can do anything, but it doesn’t really fit the description of being able to access the logs and see the errors there (though I don’t know what exactly the errors say).

Current Audacity does not use RAM for edits, except that some Nyquist effects load the track data into RAM. When that happens and there is no RAM left, Audacity crashes.

Reverb is not a Nyquist effect.


My advice was for trying to stop the problem, not trying to access the logs. I didn’t think reverb was a Nyquist, either.

It’s a perfectly reasonable suggestion, but all I was trying to say was that if the machine was very short of RAM then doing something like opening another window in Audacity probably wouldn’t even display the window properly.


It would only mean opening a different one, not an extra. I did it when I had the same problem and fixed it.

My first move would be installing Audacity on the daughter machine and seeing if that solves the problem.