Stops recording at 12 seconds [SOLVED]

I have an M-Audio Firewire Solo interface on a Windows 7 PC using Audacity 2.1.0. Last used the prior program about 1 year ago and worked fine. Updated to new Audacity version in April. Now, when I hit record, a waveform is recorded for 12 seconds, then disappears, recording of the waveform resumes for another 12 secs and then disappears…etc. etc. etc. If I hit stop in mid-recording, it also disappears.
Any thoughts?

Look at Edit > Preferences… then the “Directories” section and make sure you have permission to write to the Audacity temporary directory and that it has sufficient space.

Turn off any file cleanup applications that may be deleting files in Audacity’s temporary folder. Norton is a known offender.

Using File > Save Project As… before you record and saving to your own Desktop would be another solution. If you don’t want to save projects, go back to Directories preferences and type in a folder location that does not have “temp” in its name.


When I went into edit > preferences > directories - it shows the the temporary files location as /audacity_temp with 846 GB of free space. When I search for that location I cannot find it. When I try to choose a location to put the temporary files , i.e. Desktop, Documents, etc. to place the directory it tells me unavailable - above location does not exist.

Any thoughts…

Actually, went back and was able to create the new temporary file location. Now it works. Gale, thanks for the help.