Still No Exporting to same folder

All of these new updated versions & it still won’t export right, and I reported that it will not export back to the original folder it came from in previous versions, defaults to Documents.
Sometimes it may go back to it a few times but then goes back to Documents. It won’t open to export back to where it came from.
If I’m working from another drive it’s time consuming to fidget from Documents back through the drives, then to the folder & it’s very frustrating.
In the exporting section it says to leave blank to go back to the original folder but that still doesn’t work.
I guess I’ll go back to Izotope but it upconverts to 32 bit float when I’m just changing volume level so I have to use dither.
Why can’t they fix this problem? Otherwise it was a great problem up until a certain version after 2.02 I believe.

You can change the default Export directory to the drive where you usually export. See:

They can’t fix it because it isn’t broken. The default export directory was made into a customisable Preference setting in response to user demand. Some users were highly vocal about wanting this.

Personally I would have preferred that the default was the same folder as used last time, unless a default path was set in Preferences.

That is precisely what this page says happens:

where it states

If a particular action’s default folder is left blank (default setting) then Audacity will offer the last-used location for that action.

I.e. an export will go to the Export location that was last-used.

What it specifically does NOT do is provide for Export to where a file was imported from - and this is because a project to be exported can readily be made up of several imported audio files each from different locations - so where would Audacity then decide to offer to the user as an export location?