Still having problems with audio out to earphones

Hi,
I seem to be having a fair few problems since updating to Audacity 3.2.1 running under Monterey 12.2.1.
I am now getting an error message when I try to run audio out to earphones. I had this working OK a few days ago and on starting to iuse Audacity today it refuses to play through to earphones in spite of this being selected in “Audio Setup”. [see screen shots]
As said all was well until now and I’ve not knowingly ‘tweeked’ or changed any settings.
Can anyone help out here, please?
Mamny thanks,
TonyT
Screenshot 2022-10-31 at 16.53.41.png
Screenshot 2022-10-31 at 16.44.21.png

Well now I am confused about this audio-to-earphones issue.
I launched Audacity again today and audio to earphone sjust simply worked.
I’ve no idea why (as per my previous post) I was having problems.
Anyway, I guess this topic shouldnow be flagged as “solved”.
I do suspect a possible bug in this latest version though
TonyT

Windows guy here. I can’t tell you about Mac, but on Windows, if I were to temporarily lose connection to a USB device, then the Windows pointers to the device might change and Audacity could no longer use it.

To solve this problem (on Windows), restart Audacity, or simply do Transport > Rescan Audio Devices.

I suspect this trick would work on your earphone issue as well.