Stereomix recording on Win7?

I’m sorry, I think this question has been asked many times already but unfortunately I couldn’t get it to work reading the wiki.

So I have Audacity 2.0.3 and Windows 7 and I wanna record the sounds my computer “makes”. At the recording tab I have “Stereomix” selected but I can still not record stuff.

Can anyone help me?

In Windows “Sound” you have to enable stereo mix by right-clicking over it. It can help also to make it default device (another right-click over stereo mix). Single-click selecting a device does not enable it or make it default.

Having enabled stereo mix and made it default in Windows, restart Audacity then choose stereo mix as input device in Device Toolbar .

You need to play the sound you want to record on the built-in sound card. Listening to it on USB headphones means you cannot record it with stereo mix.

You have to be able to hear the computer playback or it won’t record.

You can try SoundLeech (free) or Total Recorder (costs money).


Gale

Thx for the post.

But I have already done all that, stereomix is enabled and a default device, in Audacity it is set as recording device but it’s not working (for example when I’m playing a Youtube vid).

Sorry, but we can’t see your computer and so it is hard to fix it for you if you have followed all the suggestions you have seen.

Are you sure you have the correct drivers for the sound card made by the computer or motherboard manufacturer? If you have 64-bit Windows 7, are the sound card drivers 64-bit: http://wiki.audacityteam.org/wiki/Updating_Sound_Device_Drivers ?


Gale

Updated the sound drivers through the website of my motherboard but still doesn’t work. I have no idea why…

When you look in the Device Manager, which driver does it say is in use by your sound card? Who does it say is the “Driver Provider”?

It says “Realtek High Definition Audio”.
Driver Provider: “Realtek Semiconductor Corp”.

When you have stereo mix enabled and default in Windows “Sound”, does Windows Sound Recorder record computer playback?


Gale

Is your computer a branded computer? If so, check the manufacturers website for drivers for the appropriate make, model and operating system.

Nope, doesn’t seem to work.

Is your computer a branded computer? If so, check the manufacturers website for drivers for the appropriate make, model and operating system.

I have acquired the sound drivers from the website of my motherboard.

Then it’s not an Audacity problem. You can try SoundLeech or Total Recorder as mentioned before.

If you have a branded computer (like one made by Dell, HP or Lenovo) it may not be the best decision to get a sound card driver direct from the motherboard manufacturer. It could be the reason for your problem. A branded computer may have dependencies on a sound device using a particular sound card with its particular control panel. That sound device may not necessarily be Realtek.

What is the make and model number of the computer? Did you build it yourself?


Gale

recording function of my Thinkpad X201T is disable by Lenovo.
This is what I did。
I bought an Asus Xonar U3 USB sound card , 3.5mm audio cable both end。
After installing the USB sound card, click Speaker (Asus Xonar U3) as output device,
click Line in (Asus Xonar U3) as input device。
Plug 3.5 cable into the headphone and microphone on the USB sound card。
Recording was nice and clear, except the volume could have been louder。

Thanks, plion.

If V-K has a blue line-in port on their computer then (s)he doesn’t need to buy a USB sound device.

Unfortunately we don’t know any details of V-K’s computer.


Gale