stereo mix problems

I have been trying, on and off for nearly a year now and pretty intensely in the last week, to get the stereo mix problem sorted and still nothing.
My system comprises; W8/64bit pro with media centre, asus crosshair v formula mobo, amd 6 core processor, 8gb ram, Creative Audigy SE soundcard. I have main spkrs in the green jack, headphones in the black jack, nothing connected to the blue in or the orange out. My Realtek drivers (R271) are up-to-date. There are no recent updates to the card software (currently version / dated 03/08/2009). It is set to 4.1 and I can only change the Creative Soundblaster settings thru the ‘audio control settings’ from the ‘soundblaster’ tab in ‘speaker properties’. There is no win8 support from Creative for a full interface. All the bits n bobs from Creative are installed on my pc but only ‘audio control settings’ and ‘Wave Studio7’ are functioning.
I have plugged something in to the blue line-in and Audacity recorded it - no probs.
In sound properties - ‘show disabled’ and ‘show disconnected’ is checked, everything is disabled except my speakers turned up full (creative drivers) in playback. Everything is disabled in the ‘recording’ tab of ‘sound’ except for ‘stereo mix’(realtek high definition audio driver) which of course, does not light up when ANYTHING is playing in the background. The level is up full and it makes no difference if the ‘listen thru this device’ is unchecked or not. but I dont know the difference between ‘default playback device’ and ‘speakers (sb audigy)’ concerning the ‘playback thru this device;’? either makes no difference
It has been suggested that I will never get this problem solved owing to the way my mobo has been wired to crack down on users directly recording fom the interweb. I also tried plugging my speakers into the line-in jack…to no avail.
I still can’t tell wether this is a problem with my mobo, soundcard, W8, Realtek or Creative.
Any suggestions welcome - thanks in advance.

You may be a candidate, at least in the interim, for the desperation method.

Put a 1/8" stereo jumper cable…

Between the Headphone-Out (or Line-Out) and the blue Stereo Line-In.

Tell the computer to play its sounds to the sound card regular Headphone-Out, but tell Audacity to record from the sound card Line-In.

Audacity > Edit > Preferences > Devices > Recording > Device:

This is where it gets messy because I’m not a Windows elf, but see how far you get with just that.

You need to know that you can throw Audacity into continuous monitor mode without going into Record in order to test the system.

Make the sound meters much bigger by dragging the right-hand edge to the right. The other icons and tools will get out of your way.

Right-Click inside the red recording meters and pick “Start Monitoring.”

From that point until you stop it, the meters are now active and watching your system.


Yes, thanks, i was aware of this dodgy method of looping a jack from headphones to line-in but the loss of quality don’t bear thinking about.
In sound properties, there are both Realtek and Creative versions of the various ins and outs and there is probably a conflict between Realtek and Creative? I bought a sound card for all the right reasons, seems a shame to uninstall it.

The upcoming 2.0.4 release will contain a new feature to enable you to uses WASAPI as your host in Audacity (Rather than MME or WDS) and use WASAPI loopback in software - I just tested this on the Release Candidate version and it worked well on my W7 laptop.

You can try the Release Candidate if you wish - see this thread:

If you do test this, please post back with your results.


Now its working. I firstly disabled Realtek, SB worked with but no ‘stereo mix’. Then disabled SB and re-enabled Realtek with on-board sound moving my output jacks to the mobo, ‘stereo mix’ now works and I’m able to record audio streams. I also have the Realtek audio control interface. The sound quality is ok but would still prefer to have a dedicated soundcard that had the functionality of RT but with decent hi-fi sound. in summary the two drivers were in conflict, I kind-of assumed that they performed separate but overlapping functions…ho-hum.