Stereo Mix is Not Working

I am using Audacity 2.0.1 to record audio to synthesize sirens. Only issue I have is, the Stereo Mix doesn’t return audio. Everything is set up the way it should be, yet the only audio it records is a pop at the beginning. I don’t see how it isn’t working since, as I’ve stated once already, everything is correctly set up and enabled.

You can set Audacity to monitor the incoming audio by right-clicking inside the red recording meters and selecting Start Monitoring. The meters are now active and running, so if you make changes, they should appear.

You selected Stereo-Mix, right? Did you also select anything else in Windows Control Panels? Stereo Mix allows you to record Sound Playing on the Computer, but if there is no sound playing on the computer, then you don’t get anything, anywhere.

I don’t know that we established what you’re trying to record.


I have selected Stereo Mix and have also made sure Stereo Mix was enabled with Windows… I am trying to record a raw waveform that I am trying to record in 2 possible ways: via exported WAV file or via an AUP save file. Neither have done much good. I’ll try the little red things to see if those work. *EDIT: The red things are already working.

I am trying to record a raw waveform that I am trying to record

Let’s start there.

… What … ?

You created a sound pattern on the Audacity Timeline by hand-drawing the blue waves? Where did the show come from?

Don’t jump ahead. We have to build your show in our heads to straighten this out.


I generated some sine waves and put them together. I could have worded that phrase a little more educatedly to be honest, what I meant was "I am trying to record a series of Sine waves via 2 possible methods: Via exported WAV file playback in Windows Media Player, or via AUP save file playing in Audacity.

Exporting should work… There’s no need to “record” digital audio that already exists in Audacity or is otherwise on your computer in memory or on your hard drive…

Do you hear the sound when you play it in Audacity?

Once it’s on the timeline as blue waves, the green sound meters should bounce…


Edit > Preferences > Devices > Playback > Device > ??

Mine says “Speakers (High Definition Audio)” and I can clearly hear my show. What does yours say?


Mine say the same thing. *Edit: I figured out that if I export the file then re-load it into Audacity the waveform stays and I no longer need Stereo Mix. Thanks for the help though!