Staticy clicking noise appears at random times during recording

I am using an iMac (mid 2011) running OS 10.9.5 Mavericks. I am running Audacity (Although the 2.3.2 version is supposed to be 64 bit my computer under “Applications - Audacity” is not recognizing it as 64 bit. See attached screen shot) Whether that is related to my problem I don’t know.

I have successfully used Audacity for years to record streams from online radio stations but I began getting some odd behaviors 2 months ago. I looked at the Forums and saw that there was a new version of Audacity, 2.3.2, and so I installed that. At first all seemed fine but soon my recordings, usually after 10 or 15 minutes - although actually it’s quite random - would develop a background ‘clicking’ type sound that ruins the recordings. I had been using Soundflower with the earlier Audacity version but when I switched to 2.3.2 and still had problems I installed “iShowU” and while that made recordings possible it didn’t cure the intrusive static sounds. I’ve tried all different settings but can’t figure out what is causing this. Sometimes the clicking doesn’t occur (last night I made an 80 minute recording that was fine) but sometimes it starts right away or, more commonly, after the recording has been going a short while. I’ve shut down all other programs running, rebooted, tried different stream sources, etc. but I’ve not been able to discover any pattern as to when it’s a problem and when it’s not. Does this sound familiar to anyone? Help.

That sounds like this issue: FAQ:Recording - Troubleshooting - Audacity Manual

I do have a very similar issue.
iMac from a similar year made, with mac OS Mojave.

I have used Audacity for about 5 months with Yamaha mixer MG12xu which has built-in USB interface.
Until recently Audacity has no issues at all and worked great.

It seems the issue began after I upgraded Audacity about 2 weeks ago from my older version.
Mostly the recording is ok, but randomly it adds noise and “distortion” of voice for less than a seconds of duration.
It is mostly reproducible when I append new recording by hitting a red recording button, which creates a separate track.

It is a mixture of “noise and distortion” of recorded voice for a second or so.

(Possible Solution)
After uninstall and reinstall an older version (2.0.x), the symptom is not visible anymore.

I think that’s a different issue, possibly related to this bug:
If you would like to discuss this issue further, please start a new topic.