Static Recording PROBLEM

I’ve been using Audacity for years with no issues. I got a new MacBook Pro over the last year and am running OSX10.9.5, and my Audacity is 2.0.5, installed with dmg I believe. I used Audacity without issue on this new computer for months. Suddenly I started being unable to record due to static clicking. It’s almost like a delay, with digi-drop outs. It’s bumming me out! I record from a turntable. I tried directly from a USB turntable, and then I tried via a different turntable through the Phono Box USB V. Sometimes the problem doesn’t happen for a minute or two, but then it starts again. I currently cannot make any recordings. Please help?!?!?!

By the way, I’ve tried both USB inputs on the computer, to the same end…

The current Audacity version is 2.0.6 though that may not make any difference.

Try Audacity > Preferences…, Recording section. Experiment with different “Audio to buffer” settings. A lower buffer setting might help.

If you just added a lot of extra apps, try turning off the ones you don’t need.

Turn off the WiFi if you don’t need it.


i feel stupid. i tried those things and nothing worked. then i tried restarting the computer and it’s fine. sorry to waste your time!

No problem. All computers need rebooting some times - it isn’t just Windows that suffers without a regular reboot.