Spectral delete not working how I want it to


I’m a very new user of Audacity on Catalina 10.15.6 and Audacity 2.4.2. I’ve been working on an arrangement and fiddling around with the Spectrogram feature to edit percussive elements to how I want them to sound - since I don’t have a drum kit, I’ve been creating household drum sounds such as banging two sofa cushions together for a bass sound then boosting it. Because of these, ah, unconventional methods, I’ve gotten some strange sounds in the sample that I don’t want, and I haven’t had any issues with editing them out (using the Spectral delete/multitool/parametric EQ/shelves) until now. When I tried to edit my most recent recording, I realized that when I used any Spectral edit feature listed above, it would just create MORE sound. See screenshots for an example of what I mean using the Spectral Delete tool; it’s a little hard to describe. Why is this happening and how can I simply remove what I want to remove without creating new issues? TIA!
Screen Shot 2020-08-08 at 4.34.56 PM.jpg
Screen Shot 2020-08-08 at 4.35.05 PM.jpg
Screen Shot 2020-08-08 at 4.35.11 PM.jpg
Screen Shot 2020-08-08 at 4.34.45 PM.jpg

As far as I can tell from the screenshots, it’s because you are making such short selections.

If there’s a sudden change in the frequencies present, it creates a discontinuity (a “kink”) in the waveform. To avoid this, the spectral effects have a short fade-in / fade-out so that the transition at the ends is not too abrupt. If the selection is very short, then there is not enough time to fade in / out smoothly.

I’ve tried widening the selection and it doesn’t appear that’s the issue. Anything else you can thing of?