SoundFinder and SilenceFinder commands not accepting parameters

I have a simple problem. I’m trying to run the SilenceFinder and SoundFinder commands with parameters set by me in my python script. Problem is the parameters I enter are being ignored and audacity is just running the SonundFinder\SilenceFinder commands with the last used settings.

Basically I’m trying to run:
do_command(“SoundFinder: sil-lev=30.0 sil-dur=1.0”)

But all is happening is:

Is there a problem with my command and what should I do?

You may need to pass the full set of parameters:

SilenceFinder:labelbeforedur="0" sil-dur="1" sil-lev="30"
SoundFinder:finallabel="0" labelafterdur="0" labelbeforedur="0" sil-dur="1" sil-lev="30"

Note: The next Audacity release replaces Sound Finder and Silence Finder with a new, more flexible effect called “Label Sounds”.

Or maybe not. I’ve just tried sending:

SilenceFinder:sil-dur="1" sil-lev="20"

using “”, and it worked perfectly.

Nope. I tried using the to send SoundFinder: sil-lev=‘30’ sil-dur=‘1.0’ and no luck. What could be the reason for that??

Which exact version of Audacity are you using? (look in “Help menu > About Audacity”)

How are you running Python? (and which version?)

Audacity 2.4.2 and Python 3.9 . The problem is still there, but I have another more important question regarding commands in audacity: My client is german and he is running a german version of Audacity, and I thought the scripts and commands should be the same, but for some reason they aren’t. He is saying Audacity isn’t recognising the english commands. Where can I find a list of the commands in other languages? Such as SilenceFinder.

If you share your macro text files (as described here: Macros - Audacity Manual) Audacity should handle the translation (it does here, but I’m using Audacity 3.0.0 (pre-release version)

Thanks a lot! Everything is working fine now :slight_smile:

Just one more question, which might sound a bit silly, but I’m trying to export to a folder with a space in its name. Audacity is not accepting that as a parameter for Export2.

Export2: Mode=Selection Filename=(…)/Desktop/Output/2004 test4/B-Seite/Track-1.wav
Export filename must have an extension!

is what I’m getting.

How are you making the Macro? The Macro Editor should automatically add quotes around the name.
If you are manually editing the macro .txt file, ensure that you include the quotes, like this:

Export2:Filename="/(....)/Desktop/Output/2004 test4/B-Seite/Track-1.wav" NumChannels="2"