Sound levels reset to zero after I press stop


When I record sound from a USB headset, the sound levels show as I speak, but when I press the stop button, the levels reset to zero and I have an empty recording. I have recorded successfully as a test from the USB headset I am using in Sound Recorder (Windows 7).

I was using Audacity 2.0.5, upgraded to 2.0.6 from the installer and still have the same problem.



You mean that the blue waves that you had recorded vanish and you are left with a flat line?

If so, Edit > Preferences… then look at Directories. Set the temporary folder to a local drive that has the most space and that you know to be working correctly. Ensure you have permissions to write to that folder.

If you have Norton, turn off its temporary file cleaner because it has been reported to delete Audacity recordings as you make them.

To be sure, type in the folder name in Directories Preferences and do not name it as Temp or Tmp.


Yes, the blue waves vanished and I was left with a flat line.

Thanks - changing the temp directory fixed it. I had set it to a local HDD with lots of space, but for some reason that didn’t work. Changing the temp directory to be on my C drive, an SSD, fixed it. I had wanted to avoid doing lots of writes to the SSD, but I guess it can’t be avoided…

Thanks again for your help!


Although the Solid State Drive (SSD) is faster, there is as you say the question of writes (which are done every few seconds when recording) and also the question that SSD’s usually have less capacity than magnetic spinning disk (HDD) drives.

Could the HDD be failing, or not connected properly?


I opened several files at random on the HDD and they were all fine. I saved a file there with no problem. It’s a mystery!