Sound in all other programs, but suddenly none in Audacity!

I’ve been assisting an old friend over Skype as she learns to do sound editing. (I’ve become reasonably proficient with Audacity and LOVE the program!)
We are using 2.0.0, and her OS is XP (assuming with SP3 update). She installed Audacity from the exe file, and has a 64-bit machine.

Today, she called and said that, after she’d successfully recorded and played back several guitar and vocal tracks earlier in the day, the program had suddenly stopped producing sound on playback. She’s not very computer-savvy, and I assumed this would be easy to fix, but we went into Windows sound and checked all the playback (and record) settings, which looked correct. Then we tried playing sound with Quicktime, iTunes, and Windows Media Player, all of which worked fine.

So then I looked for some Audacity setting she might have clicked by mistake. The tracks were NOT muted. We tried changing the output device from “Primary sound driver” to “Realtek high definition audio.” That didn’t help. We turned “Software playthrough” and “Overdub” on and off. When that didn’t work, we re-scanned audio devices (also under Transport) and restarted the program. When that didn’t work, we rebooted. When that was no help, we uninstalled Audacity and downloaded and re-installed it using the exe file and rebooted again.

None of this helped. She was sharing her screen with me, and I could see Audacity playing a typical waveform and watch the playback output level indicators as they showed sound being produced, but we could hear nothing. We opened pre-recorded MP3s and wavs, and she recorded a few seconds of speaking while I watched. It recorded just fine—again, the waveform was just what you’d expect—but as it played, there was no sound.

We also checked the driver in Device Manager. It had NOT been updated recently, and Windows told us it was the best driver available.

I’m at a complete loss. Is there way to mute the program that I don’t know about? I couldn’t find any apparently-relevant settings under Edit>Preferences. Of course, I can’t imagine why anyone would want to mute all playback anyway!

As I said, every other audio program on her machine is producing sound just fine. Thanks in advance for any help you can give!

At the risk of getting all Help-Desk on you, I didn’t see “Restart the Machine” in that monolog (which was very complete and helpful).


Thank you for responding, but " When that didn’t work, we rebooted. When that was no help, we uninstalled Audacity and downloaded and re-installed it using the exe file and rebooted again. " (end of para. 3)

For the sake of completeness, you should reset Audacity settings to Audacity defaults. This is done not by re-installing Audacity, but by quitting it and editing the audacity.cfg settings file. Please see the instructions to do this here.

It seems like you have checked most things, but has your friend turned up the Audacity output volume slider (the left-hand one) on Mixer Toolbar?

Is she actually using the inbuilt Realtek device to listen to audio in other programs? If she is using some other device like a USB headset, she has to select that as Audacity playback device, or set it as Windows default and choose “Primary Sound Driver” in Audacity.


Thanks for responding, Gale!

When I work with my friend again later today, we’ll reset the Audacity settings to their defaults and let you know if it helps.
(Yes, the output slider was up and all programs were using the Realtek device…)

Neither Notepad, nor Wordpad would allow us even to find, much less open audacity.cfg, even though we made sure to uncheck “hide system files” in folder settings. (I’m sure you know these are very secure folders…)

Resetting security settings is SUCH a nightmare that I couldn’t ask my not-too-computer-savvy friend even to try that after we’d tried over and over to open the file in various ways, including dragging it into the text editors (When we did that, Wordpad showed only the icon.)

Anyway, we uninstalled Audacity and deleted every possible remaining Audacity-related file afterwards, including audacity.cfg (used the free and excellent “Everything” search tool). Then we created a new audacity.cfg in a text editor, typing only “NewPrefsInitialized=1,” re-installed Audacity2.0.0,and rebooted.

None of this gave us sound in Audacity. (As a result of these problems, she started using Mixcraft, which she purchased recently. It worked fine for us.)

My intention now is to again delete all things Audacity and then to go into Regedit and delete all references to the program. (backing up the Registry 1st, of course) and then to re-install it. I now understand that Audacity’s configuration info is stored in the registry. I think it’s keeping those settings in spite of the uninstall and the edited cfg file.

I’d be happy for any suggestions about finding related registry entries that might not contain the term “Audacity.” I doubt there could be any, but there’s a lot I don’t know!

Thanks in advance for any responses!

I have never had a problem opening audacity.cfg in Notepad, certainly not when dragging it in.

The next 2.0.1 release of Audacity will have an installer that lets you reinstall and reset the audacity.cfg file automatically at the same time.

Did you place the new audacity.cfg in Documents and SettingsApplication DataAudacity while Audacity was closed? It will have no effect if you did this while Audacity was running.

No, the 2.0.0 settings are stored in Documents and SettingsApplication DataAudacity.

It won’t be keeping any explicitly configuration settings in the Registry unless you have previously installed Audacity 1.2. And even if you have, “NewPrefsInitialized=1” would make Audacity ignore the 1.2 settings.

Have you tried System Restore back to before the date when the problem started?


Thanks for the multiple responses since I last commented here.

Since that time, we again uninstalled Audacity and searched for and deleted all residual Audacity files (again, including the audacity.cfg file kept in “Documents and SettingsApplication DataAudacity/”).

We then followed advice I found on another site and deleted all references to Audacity in the registry. (That suggestion had been provided in response to someone having a problem similar to ours.) Following all this, we rebooted and re-installed the program.

Again, no sound, no matter what file we tried to play! (The files are not muted, nor is the volume turned down in the Track Control Panel.)
All other audio programs are working normally.

To remind folks… Audacity worked fine for my friend for a couple of weeks. Then, one day last week, after she had successfully recorded, played back, and started editing a three-track file in the morning, she returned to work more that afternoon and discovered that Audacity had stopped making sound, even though her files were clearly playing and the meters showed sound being produced. She assumed she had somehow clicked the wrong control by mistake.

I can’t program, but consider myself a fairly advanced Windows user, and I’ve spent hundreds of hours in Audacity over the past month with no problems. Nevertheless, I can’t figure out what’s causing this. We’ll be extremely grateful for any additional suggestions.

Quick follow-up… We did do a system restore.

Also, I realized last night this must a a problem in Audacity’s output device settings. I’m sure we looked at them, but we’ll take a closer look tonight Audacity is receiving and playing sound, but not sending it to the speakers or headphones. I should have realized this before.

I plan to post the results of our efforts here.

Hardly surprising since no audio configuration settings for Audacity 1.3.x and later are kept in the Registry.

Back to a time when Audacity produced sound? And it didn’t make any difference?

Then the Realtek sound device will need drivers meant for Windows XP 64-bit, supplied by the computer or motherboard manufacturer (not by Microsoft). See .

Also, is Skype running? If so, ask your friend to quit Skype completely using the system tray icon or Windows Task Manager.


We will try installing the 64-bit drivers: however, I will point out again that the program had been working fine on her 64-bit machine for several weeks before the problem arose. Also, we have worked OVER Skype repeatedly and without difficulty in Audacity on her machine.

We had device manager look for updated drivers on the machine and on the Net. It said we had the most up-to-date driver available. It also gave no opportunity to roll back the driver (grayed out)

Even though we’ve worked over Skype with Audacity in the past, she quit Skype completely and attempted to play a file in Audacity to check out Gale’s suggestion. Again, playback meter indicates sound being produced, but no sound comes from speakers.

We tried changing playback settings in Windows sound today, so far with no luck.

Then, one day last week, after she had successfully recorded, played back, and started editing a three-track file in the morning, she returned to work more that afternoon and discovered that Audacity had stopped making sound

What day exactly? Day of the week?

You have a fuzzy gap in there. You can understand why we’re really interested in the time and date of the failure. She was editing a show and then …[gap]… she starting editing again and Audacity was silent. Does she leave the machine running with Audacity and just sit down again with a fresh cup of coffee after lunch? Does she shut Audacity down and then open it up again? Is she actively working on email or Skype or any other application during this gap?


Audacity is usually so reliable in its recording and playback that we used to use it to confirm signal continuity in recording and entertainment systems. It’s most unusual for it to fail like this.

She doesn’t remember anything during the gap because that’s when the aliens came…


Who was the driver provider? If it was Microsoft, they are the wrong drivers, not matched to your motherboard, however up-to-date they are.


(Parts of this message may end up duplicating a post I submitted yesterday that, for some reason, hasn’t yet appeared here.)

Well, we were not successful at getting sound in Audacity by changing the output configuration. I believe we tried all available settings in the program and in Windows sound. I’ve run out of ideas…

To answer your questions, Gale,

Yes, the system restore point we used was made while Audacity was still working. It had been automatically created by Windows when it did a critical system update earlier on the same day Audacity quit working. I know that sounds suspicious, but the program worked for several hours after the update and, more telling, Device Manager offers no opportunity to roll back the driver. Also, Device Manager searched her machine and the Net for the latest driver and said she has the newest one. (Incidentally, I believe we used the only existing SR point. Guess we’ll need to change her System Restore settings so it saves more than just one!)

I had her shut Skype down (completely QUIT it— NOT running in background), then try Audacity again, and then call me back on Skype. She confirmed that there was still no sound in Audacity when Skype was closed. I didn’t expect this to have any affect, because her problem had initially arisen when she was not using Skype and, before the problem arose, she and I had done a good deal of work together in her Audacity program while we were sharing her screen over Skype.

Thanks again for your help, Gale. I remain open to suggestions!

Sorry… For some reason, I didn’t see some of the above comments/questions until now.

I’ll try to get more details about exactly when the problem arose and just what she was doing that day, especially between the time the program made sound and when it no longer did. It’s now been a week and a half or two since then. I hope she has some recollection. (As I mentioned, she’s not at all computer-savvy.)

All she told me was that she had recorded several tracks in the AM and things had been working fine. She said she then took a break and stopped working in Audacity for a couple of hours and, when she came back to listen to her recordings and send them to me, she couldn’t get any sound. (I’ll ask if she’d closed the program during that hiatus.)

Next time I talk with her, I’ll find out if the driver is from Realtek Semiconductor like mine.

I think I should again mention that sound plays fine in all her other audio programs. (inc. iTunes and Windows Media Player)

It had been automatically created by Windows when it did a critical system update earlier on the same day

So that would be Tuesday.

(I’ll ask if she’d closed the program during that hiatus.)

That would be good to know. Most well-behaved updates wait until the machine is loafing before applying updates, and service modules may not update until the program is stopped and restarted.

I really want to split up the system. Do you/does she have any usb sound “loudspeakers” to use an older phrase? Anything USB, speakers, amp systems, headphones. interface devices? You see where I’m going with this? A method of getting sound out of the computer without going through the conventional sound services.


when she came back to listen to her recordings and send them to me, she couldn’t get any sound.

Did she send them to you anyway and what do they sound like?
In My Opinion, you should trash Audacity 2 and install one of the earlier Audacity versions. I think I was happy with Audacity 1.3.13 or 1.3.14 before I finally did the global update to push my machines to 2. In the overall scheme of things, Audacity 2 is very new and we may not have found all the problems yet.

If the System Restore didn’t bring things back to life, that’s pretty scary.


2.0.0 was produced from very similar code to 1.3.14. In my opinion, you would have to go back to 1.3.12 to find much difference in audio input/output code.