Sound Drops Out During Recording

I have a problem when recording streaming audio that at some point during the recording the music suddenly gets deleted . I have tried other recording software and this doesn’t happen with that software.
Everything is up to date, I’m using Windows 7 Ultimate with a Creative USB Sound card.

All of the audio or just portions, dropouts like in the title?

If you have an aggressive virus protection software, it can prevent Audacity from writing to the drive, basically whenever it feels like it.

I would use the other software.


If I am recording an album I can get up to 30 mins recording then all of a sudden the recorded bit will just delete itself and leave a blank space where there was recorded audio, and then carry on…My only solution so far if using Audacity is to record track by track and save each one…I have tried other recording software such as sound tap and Creatives wave studio 7 and I don’t have this problem.

It sounds like some program is being “helpful” and clearing out Audacity’s temporary files when the temp folder gets to a certain size.
Do you have Norton 360 or anything similar installed?

Oh. Classic “dropout” is when you’re missing one note in the middle of a successful song. That’s what threw me.

If I am recording an album

That’s not streaming audio. Streaming is when you’re recording YouTube or a podcast. Does it happen with both?

So you’re recording right along and the music will go silent and the blue waves will vanish? Do you listen to the Audacity playthrough while you’re recording and does that go silent? Does it pick up again after the damage or does it halt?

It sounds to me like you’re running out of hard drive space and Audacity is starving for resources. When Audacity is running for a couple of seconds, does it say way at the bottom of the window how many hours you have left to record? (attached).

Screen Shot 2015-03-19 at 13.48.16.png

When I mean recording an album I am recording music while it is being streamed on a website. I have 2 TB of hard drive space so I don’t think that is the problem. Audacity says I have 1400 hours of recording time. I can’t work out why it is only Audacity that it is happening. The blue waves disappear and there is nothing to play when I go back to the start of the recording. I use the “record what u hear setting” and this hasn’t been a problem until I took the latest Audacity update.

Did you also take an update of a cleanup software that is deleting the contents of the Audacity temp folder as you record? By default Norton deletes Audacity recordings as you make them. Cleanup software or using a flaky or network drive for your Audacity temp folder are the most likely causes.

Edit > Preferences… then look in the “Directories” section. What is the location of the Audacity temp folder? If cleanup software is the problem your choices are:

  • Add an exception in the cleanup software for the Audacity temp folder or turn the cleanup off.
  • Change the Audacity temp directory to a custom folder that does not have “temp” in its name.
  • Before recording, File > Save Project As… and save to a folder that does not have “temp” in its name.

Depending on the web site, you may be able to download the songs instead of record them, assuming you have permission to record the songs in the first place.


Thanks for the helpful suggestions I will see how things go…