Sound corruption in the latest build with ASIO

The issue is back (A couple of issues with the 1.3.15 ASIO build) so I’m going to start saving everything and keeping track of things. Here is my current config (that’s giving my the sound corruption).

Of course this reared its head after I finished a double LP. I had just recorded both sides, cut out the extra sound my level test and from the drop at the beginning of side a, saved the file and when playing back to start cutting out the extra between sides I heard the bad audio. I know I missed a couple saves but I’m currently recording the whole thing again step by step to see if it happens again.

Oh same setup as before but now with the 2.0.1 ASIO build. I removed the old installing, cleared out my config, installed new version with executable and overwrote the installation with the files I got from compiling.

EDIT: Below is after recording album again.
Ok here are the steps taken so far to reproduce issue. This is all on the 2.0.1 ASIO build only (with the current config saved and uploaded). After every step I saved, closed audacity, and reopened newest file, played for any issues and then moved on.

  1. Recorded full album (all four sides)
  2. Made two random cuts in the time between me flipping side c to d and from me walking back to stop the recording. (essentially 75% in and after the end of the record, will call it 110%)
  3. Silenced from beginning of side a recording, the drop of the needle, and right before start of first song. Added labels for Knuckle Down, and Studying Stones (for point of reference I’m working with Ani Difranco Knuckle Down)
    4. While playing through Manhole, labeled it, I noticed a pop, selected section and repaired it.
    —This is where I noticed sound was corrupted after attempting to start another step.

I have all of the above steps saved. I’m not sure what I should upload and include. Interesting to note, everything (while skimming) before track 3 (Manhole) plays without issue but something happened after the edits and save, everything after track 3 is messed up.

I’ve been awake for awhile (work 3rd shift) so I’m probably going to bed soon. Will reply ASAP.

Of course this reared its head after I finished a double LP.

I’m sure the developers need to know if there are build problems, but are you sure you need ASIO for recording an LP???

From what I understand, the main advantage of ASIO is low latency. Of course, latency is of no concern when recording an LP. There may also be the ability to get exclusive control over the soundcard/device and the ability to prevent resampling during playback, but none of that should affect the quality of your recording.

About here, in my last post I mention the 16 v 24 bit noise floor issue… ASIO is necessary in this situation.

probably not a solution that you want to consider, but you could try a different operating system.

I’m not clear - are you saying that the corruption was a result of repairing the pop, or was the corruption present in the original recording?

If you are getting corruption in the original recording, try reducing the sample rate from 96 kHz to 44.1 or 48 kHz (I’d guess that the audio bandwidth of the material you are recording does not exceed 20 kHz. 48 kHz sample rate will quite happily exceed 20 kHz).
You could also try increasing the latency in your ASIO settings.

It’s not the first time someone’s suggested that but switching isn’t really an option. I don’t understand why (1) people are against or don’t support ASIO, if it’s the only way to record properly at that level (2) there is no better way to record on Windows. It begs the question why is Windows still broken after all these years…but I know that’s a different topic for another place.

The sound corruption only comes in after modifying the original recording. The first recording of the record I was testing levels, found the right one and left that and the entire record. When I silenced all the extra “stuff” at the beginning of the record and played back from track one (at the correct recording level) I noticed the bad audio while playing back.There was no repairing yet of any kind, only silencing a section of the record. Restarting everything and keeping track of every detail the second time around, with a fresh recording had the issue crop up after a (1) few cuts, (2) labels, (3) then repairing the pop.

It’s definitely not consistently one type of edit every time. When I noticed the issue last time I only noticed it happening after I completed editing the entire record. I’d go to reopen it for some reason after taking a break, say to export the final product and it would sound like craziness. Back then I was super frustrated and I just started deleting preferences and stuff and Gale suggested if it ever occurred again to try and keep track of it. Which is what I’m trying to do now.

It’s because the ASIO license terms are incompatible with GPL (Audacity is licensed under GPL v2.)

Audacity is not legally allowed to be shipped with ASIO support - the Steinberg license specifically states that the ASIO SDK is non-distributable, so unless either Steinberg change their licensing terms Audacity cannot be shipped with ASIO support (Audacity is legally bound to remain free, open source software so that can’t change, nor would we want it to). More info:

It’s possible and quite likely that will improve in the future. Windows now has WASAPI which is capable of much better performance than previous Windows sound systems. These things take time - driver support for sound cards after the changes from XP to Vista took years to stabilise (and driver problems on Vista / 7 are still not uncommon). PortAudio (which Audacity uses for audio capture) have been working for a long time now on supporting WASAPI and I think that WASAPI support may now be included in their stable version, so we can hopefully look forward to better audio on Windows when Audacity updates its version of PortAudio (though it’s probably not as simple as just updating PortAudio - these things never are).

If you have, or you get a reasonably small project that exhibits these types of problems, perhaps you could upload it somewhere on the Internet (for example one of the free file sharing sites) so that we can take a look. I suspect that the problem may be related to invalid audio data but we would need to take a close look.

I’m sorry, what I meant was, given that I’ve done the work to get ASIO working in Audacity why is everyone always trying to get me to stop using it.

Which step do you want uploaded. I’ve saved them all. Pre or Post error? Or both?

OK I see. Speaking for myself, although I rarely use Windows, the released Windows build of Audacity is a known quantity so if a bug is reported then it’s likely to fairly straightforward to check out as long as there is a clear report of how to reproduce the problem. With any “custom” build that becomes much more difficult because to some degree it is an unknown quantity.

Both if you can.

So what you’re saying is… if I can’t reproduce this in the regular release this may not, if ever be fixed.

Working on it. Uploading steps 3 and 4 They are ~1.5gb each. I hope you’ve got WinRAR.

What I’m saying is I’ll have a look at the Audacity project and see if I can find any clue as the cause of the problem. Have you ever tried to fix a problem that you can’t reproduce?

I’ve not got WinRAR (I use Linux) and prefer open formats (such as 7-Zip which is open source and fully cross-platform compatible) but should be able to open it.

I had to do everything remotely so I couldn’t open and listen to check but here are the last three steps. I can explain anything you may not understand but it’s all here.

Step 2

Step 3

Step 4

Just wondering if there’s any…umm… consensus. I’m wondering if I should remove the config, start over again, anything?

You may be starting to run up against this bug:

1 hour 4 minutes stereo at 96 kHz is about 750 million samples
If you process that file, for example if you normalize it, the number of samples in the project will double as Audacity copies the data so that you can undo the process. That will take you up to 1.5 billion samples. 2^31 is about 2 billion.

If you really need to use 96 kHz, try splitting the project in half before you start editing and see if that makes a difference.

Hmm, while similar, White Christmas wasn’t a double album (~30-45m) and my projects aren’t coming up blank…

But I’m not trying to argue your reply I will keep everything I record under and hour and keep you posted.

When I tried to open the first of your links, it came up half blank and reported thousands of missing block files.
I’m not certain that the problem is related to the “2^31 sample” issue, but it looks plausible.

The second link has just finished downloading so I’ll take a look at that now.

Huh? It shouldn’t be blank. The first 2 didn’t have any issues.
Bilderman 2012.04.22 8-33-53 PM.png
Bilderman 2012.04.22 8-31-40 PM.png
Bilderman 2012.04.22 8-28-51 PM.png

It did here.
The first 30% was fine. The next 20% was noticeably corrupted and the last 50% was silent.
I can’t rule out data corruption in the download, though the RAR file extracted OK so it appeared to be OK.

Oh my goodness. I never played that far! Let me try the first one, the one I didn’t upload.

EDIT: Ok I definitely hadn’t noticed that… All of them are corrupted. Even from the first save.

The second one does not report missing data.
It plays correctly up to 10:5.940 and from there on the sound is badly corrupted. The sound of the corrupted audio is much the same as I heard in the first project.

So there are a few takeaways from this. Definitely check the entire record before commenting. Also to make sure it’s under an hour for now (any ideas how/when that might get fixed?)

If you don’t mind, I’m going to remove the files from my Dropbox. Unless you really need them for reference.