[solved] Waveform freezes after opening

I use Audacity 2.3.3 (I recently upgraded Linux Mint from 18.3 to 20.1, I don’t remember what version of Audacity I used before but it might be an older one).
My problem is the following: when loading an audio file, the waveform is displayed correctly, but then it freezes: I can still do things (move through the sound, select zones, edit the sound, add tracks…) but the result is not displayed. However, when I save and re-open the project the changes have been performed.
When I try to record some sound, it is recorded but the waveform doesn’t appear at all.
I tried to install the Flatpak version but the problem is the same.
Could someone help me? Thanks in advance!

So I have never heard of this condition before. Perhaps someone with Linux experience can shed some light on this issue.

In the meantime, try resetting your Audacity preferences by deleting audacity.cfg. See: Where the Preferences are stored

Ensure that you are logged into an xorg session and not Wayland. Audacity does not yet fully support Wayland.

Thanks for your answers!

I deleted the whole .audacity directory, but it had no effect. :frowning:

I confirm I use Xorg!

How big is the file that you are importing?

Are you able to generate a 30 second tone (“Generate menu > Tone”) and edit it?

The problem persists even with a very small file (or when I record a short sound directly in Audacity), or with a generated 30-second tone. I can edit it, the changes are performed but not displayed — and sometimes they are when I zoom in or out, but in a strange way: the scale doesn’t correspond to the actual scale of the waveform.

What, if anything, is returned when you run this command in a Terminal window?


Do you use any non-English language settings on your computer?

Thanks again for taking the time to help me!
The command returns xim, and all my language settings are set to French (fr_FR).

Try starting Audacity from a Terminal window with:

GTK_IM_MODULE= audacity

If that fixes it, modify your Audacity menu item / launcher to use that command.

Thanks a lot, it works! :mrgreen:
However I couldn’t modify my launcher, since the = symbol isn’t allowed in a .desktop file. But I tried to savagely remove my ~/.xinitrc, and after a reboot everything was OK. So for some reason (but maybe is it a known problem?), Audacity doesn’t like the IM module to be set to xim? (And by the way I don’t know why my ~/.xinitrc did that… :confused: )

It seems that several GTK apps have problems, so my guess is that it’s a bug in GTK_IM_MODULE=xim.