[SOLVED] Record fills blank to cursor

Howdy. This is a recording problem that has cropped up repeatedly for me. It may be a software bug.

My recording device monitors correctly. So the device is correctly configured and selected, and the levels are properly indicated on the monitoring toolbar prior to recording.
Then I click record…

When my cursor is not at the start of a track and I click “Record,” the track instantly fills with blank, up to my cursor position.
When my cursor is at the start of a track and I click “Record,” I get the following dialogue:

Correction setting has caused the recorded audio to be hidden before zero. Audacity has brought it back to start at zero. You may have to use the Time Shift Tool (<—> or F5) to drag the track to the right place.

This bug crops up in some projects, apparently randomly. But once it appears that project is ‘cursed’ as it were, forever. Relaunching the program or rebooting has no effect. My only workaround is to create a new project, record my new tracks, and copy/paste into the working project. A crappy workaround to be sure. However this indicates that my recording settings are not the issue, as everything works as expected. Only afflicted projects are affected.

Has anyone else come across this issue? Any ideas as to where I can look to remedy the situation?
Any help much appreciated! Thx

Audactiy 2.2.1 (latest available in my distro’s repos)
Linux Mint 19.3 64 bit

That is normal and intended.

That was intended at the time, though it has been changed in more recent versions of Audacity. This warning only occurs if the recording is so short that latency correcting shifts the entire recording behind time = 0. It may, for example, occur if recording stalls very soon (milliseconds) after the record button was pressed.

There are many possible reasons why recording may stall. For example, if another application has grabbed exclusive control of the recording device.
To record a second track, Audacity must have access to both read and write to the recording device.

We really need more information about when it occurs to be able to diagnose the cause. It’s not due to a “bug” in Audacity, it’s due to Audacity not being able to simultaneously read from and write to the recording device.

What audio device are you using?
What settings do you have in the Device Toolbar?
What is your Project Rate? (lower left corner of the main Audacity window)
What other apps are running?

Hi Steve, thanks for the reply.

Answers to your questions are below, however I’d suggest they are all red herrings because, as mentioned, my recording set up works perfectly and as expected, except in some projects after the bug crops up (prior to which the project recorded normally - which is how I created the project to begin with).

Put another way, I can have multiple projects open simultaneously and with the same recording toolbar settings, one of which will exhibit the behaviour described in O.P. but the others behave normally. Behaviour is the same regardless if it is the only open project or one of many.

Audio device: Zoom H4n in USB interface mode (to pass condenser mics)
Toolbar settings: ALSA; Default / H4: USB Audio (hw:3,0); Mono/Stereo; Default (slashes indicate I’ve tried both settings)
Project Rate: 44100
Other running apps: None. Bug persists after a restart and fresh open.

I realize there’s not much to go on here, which is why I didn’t venture to ask for help debugging, merely whether anyone else had encountered this issue before. However if there’s any other info I can furnish, I’d be happy to do so. Thanks again for the attention!

New development: I’ve discovered that, in an affected project, if I mash the record button like a crazy person in a Metroid boss fight, it will sometimes eventually start recording. However in other projects, or in the same project before the issue appears, only one click was sufficient to begin recording.

Is the Zoom H4n set to a sample rate of 44100, and do all tracks in the project have a track sample rate of 44100?

What is your playback device?

Yes the H4n is set to 44.1 KHz.
Yes all tracks in the project are at the same rate (they were all recorded the same way - through the Zoom).
Playback device I leave at default. It plays back through my motherboard’s line-out to computer speakers, like everything else. The options under playback device are: default; pulse; hdmi; H4:USB Audio (HW:3,0); HD-Audio Generic:ALC1220 Generic Digital (hw:1,1); and six various HDA HDMI channels associated with my video cards.

Next time it happens, try selecting “Transport menu > Rescan Audio Devices”.
Then check the settings in the Device Toolbar.
Then try recording again.

So I just tried that and fiddled with the recording settings, but no dice.

What really throws me for a loop is that when I click “Click to start monitoring,” the levels show correctly. I see the live feed from my recording device. But when I click record, it will simply refuse to record. Mono, stereo, default source, device explicitly selected, whatever. And this where it worked previously in the same project and continues to work in another project. Truly baffling. This is my third affected project in six months.

Anyways I’m due to upgrade to Mint 20 as well as a new point release of Audacity, so fingers crossed the bug will magically go away.

Thanks again Steve for your help and attention on this!
Best regards.

When you “Click to start monitoring”, Audacity captures audio from the selected (recording) audio device.

When you click record and there are other tracks in the project, Audacity tries to capture audio from the selected recording device, and play to the selected playback device, at the same time (“duplex” mode). It’s this “duplex” communication that is causing the problem.

What happens if you select the H4N as the playback device (and as the recording device)?

Well what do you know! That’s the ticket!

When the H4n USB interface is selected as both recording and playback device, it records normally.
When I revert to default playback devices, it exhibits the behaviour described in OP. Like clockwork.

So the mystery is solved! Thank you again Steve for your help and persistent attention on this matter. Now I can get back to work. Whew!

Side note: I wonder if this behaviour is in fact intentional. If Audacity monitored through my desktop speakers while I recorded, it’d be a one-way ticket to feedback city. Monitoring through headphones on the H4n makes far more sense. Though an error dialogue would’ve been helpful, were this indeed the intent.

It’s not an intended behaviour, but rather a symptom of mismatched sample rates. By using the H4N for recording and playback, the H4N takes care of ensuring that the sample rates match. Similarly, if you used PulseAudio for both recording and playback, then PulseAudio should take care of it.

Audacity itself does not care what sample rates you use, so long as it is more than 100 Hz and less than … (perhaps 1 million Hz - I don’t recall exactly, but it is very high). Audacity will try to record / play at whatever sample rate you choose as the “Project Rate”. It’s then up to the computer sound system to handle it (if it can).

Makes sense. Thanks for the info!