[SOLVED]Intermittent sound and lag time recording on new W11 computer

I’ve been using Audacity and a Behringer UFO202 interface device to digitize cassette tapes with my Windows 10 laptop with great results. I just got a new Windows 11 laptop and am trying to do the same thing with Audacity but not having much luck. The waveform doesn’t appear right away when the music starts and then it only appears for a short time and then starts, stops, starts, stops. I’ve tried both USB ports on the new laptop and tried it with two different cassette players. I compared all the Audacity settings between the two computers to make sure they are the same. I’ve tried MME, Windows DirectSound, and Windows WASAPI options. When I do see the waveform, I think there is an echo. Nothing I have found gives me reliable input. I also tried digitizing a record using a USB turntable directly to the USB port. I got a better waveform but the input level slider is almost all the way to the max and the level is not hitting -6. Any ideas where the issue lies?

Audacity 3.2.5

Oops. I found a setting in System Sound settings (input format) that was wrong and changed that. Now I am getting a proper waveform but it sounds like I am getting two inputs, one slightly behind the other. The result is what sounds like playing the song in double time. If I press the stop button, the song sounds correct but of course I don’t get any input.

Double oops. I had to turn off “Software playthrough of input”.