(soft) file associations lost

(Windows 7 home premium, 64-bit)

Just installed Audacity 2.0, after uninstalling 1.3 beta per instructions. Now Audacity does not appear among the “Open Using” choices in the context menu for sound files. Further, browsing to and selecting audacity.exe doesn’t work - the program choice returns to the default (VLC) as soon as “Open” is chosen. Starting Audacity manually and using the file menu to open a sound file works just fine. What am I doing wrong?

same issue here.

win 7 pro x64. i did a clean install from the .exe installer.

I’ve got the same problem. I’ve just installed v2.0 and file association won’t recognise the exe file for mp3 files (it worked OK with Beta 1.3). The program starts OK from the filename or the shortcut. It opens mp3 files from FileOpen. But when I try to associate the exe for mp3 files (Control PanelDefault ProgramsAssociate a file type or protocol with a program) selecting the exe isn’t acknowledged and it helpfully gives me Windows Media Player.

Windows Vista Home Premium SP2 (32 bit)
I didn’t download a ZIP version of Audacity

Any help welcome

Using one of the files whose type you want to associate with Audacity:
Right-click the file in Windows Explorer

  • Open with…
  • Choose default program…
  • If Audacity is listed in the resulting window, click on Audacity
  • If Audacity is not listed in that window, use the Browse button to navigate to the Audacity EXE file and select it (it will probably be in C:Program Files (x86)Audacity or something similar)
  • Make sure the box labelled “Always use the selected program to open this kind of file” is ticked (untick and re-tick to make sure)
  • OK to exit

Remember, you can associate a file type with only one program. It is always possible that installing another piece of software might result in these settings being changed.

Further update for the attention of the senior elves on the forum:

I didn’t uninstall v1.3.14 and I don’t have this problem. Is the Windows install package for v2 as a “vanilla” install doing the file associations? If not, should it perhaps include an offer to the user to take over WAV and MP3 associations?

had you read the thread, you would realize that your suggestion doesn’t resolve the issue for the users with this problem.

I wouldn’t have posted the reply if I hadn’t read the thread. At which step does it not work and what are the exact symptoms of it not working at that step? The technique I documented is the technique I used on Win 7 to achieve the file association that I wanted.

Sorry, I thought my original post was quite clear. Audacity does not appear among either the recommended or other programs listed when “choose default program” is selected in the context menu of sound files. I browse successfully to audacity.exe, highlight it, and select “Open” (silly label in this context but this is Windows). The browse windows disappears but the lists of recommended and other programs are unchanged, so Audacity cannot be selected because it isn’t there.


Been using that procedure for years with perfect results until now. When I browse to the audacity.exe and select it, nothing happens - it just ignores it and Audacity is not added. Very strange.


On a hunch - ran CCleaner and now the Audacity file association works!

Moderator note-- See post on next page for more explanation.

Certainly adding Audacity to “Open with” for an audio file type works fine on a computer that has never had Audacity installed.

The installer should though ideally be able to set registry keys so that Audacity once installed is seen as a “Recommended Program” for particular file types in “Open with”. Also the installer (or the Audacity interface) should ideally give the option to associate certain file types with Audacity.

The problem you have in this thread comes if you have had other instances of “audacity.exe” installed or located in the past in different locations, as you would if you had Audacity Beta then installed Audacity 2.0. As the Audacity Release Notes say:

the Audacity executable cannot be added to the Explorer “Open with” hover menu if you have another version of Audacity on the system which is also called “audacity.exe”.

It is a Windows limitation. The same issue arises if an older “open with” registry key still points to “audacity.exe”, because the Audacity uninstaller doesn’t remove open with keys (or give you an option to do so).

As far as I know this is not an issue if you install Audacity 2.0.0 over 1.2.6. 2.0.0 would by default install into the same %PROGRAM FILES% Audacity directory as 1.2.6 and the open with associations should continue as they were before.

In all these cases, the simple answer is to rename the 2.0 “audacity.exe” to some other name such as “audacity 2.exe” then you should be able to add it to the open with menu.

As an alternative to trying to sort problems like this out in the Windows Registry, which is dangerous, you could try
http://defaultprogramseditor.com/ or similar programs (search on Google for others). Or indeed in some cases a registry cleaner may help as rgdave confirms.


Yep - running CCleaner fixed the problem. Thanks to rgdave for the tip, and to Gale Andrews for the explanation!

No need to run CCleaner or anything. Gale’s solution is simple and works. Just change the filename eg to audacity2.exe and the association then works without a hitch.

Many thanks

It also works on a Win 7 PC that currently has both 1.3.14 beta and 2.0 installed - mine!

Not necessarily true!

I have both v1.3.14 and v2.0 installed and can happily use the technique I described to change the file association from 2.0 to 1.3.14 and back again. There is no problem - on my system. When I take the “Open With…” option from the right-click on the .aup file I see the attached. Having the text and logo for both the 1.3.14 beta and the v2.0 identical is very confusing; but clicking the other one effects the switch-over.

I’m no expert, but: in that case what would one expect the state of the system to be after the next upgrade?

thanks for the workaround :slight_smile: all good now

The next upgrade installed into the same folder would install audacity.exe (for 2.0.1) and leave the renamed older executable for 2.0.0 in situ.

To make “open with” work with the new 2.0.1 executable you would have to delete the 2.0.0 executable and rename the 2.0.1 executable to the same name that you gave to the 2.0.0 executable.


I am sure the others here are using your (the correct) technique, but are both your Audacity executables for 1.3.14 and 2.0 named the same?


Yes, they are. Both installs are totally “vanilla”, taking all the default values as set by the installer software.

I suspect the difference is that all of us who are having the problem had 1.3.14 installed and uninstalled it, per the instructions for upgrading, before installing 2.0. That’s certainly the case for me.