There is no input when I try to record using my mic. I have clicked “Monitor Input”. My computer is new. I just bought a Blue Snowball mic. Audio I/O preferences are for Blue Snowball to be default recording device. What am I missing?


Is the recording volume turned up? It’s on Audacity’s main screen, with a small mic icon next to it.

If that’s not it, can you record using a different audio recording program like Windows Sound Recorder?

It sounds like the Mic isn’t set up correctly in your OS.

Also note that you need to make sure that the Snowball isn’t the audio output device - because it won’t play anything!

Hi Everyone,

Just picked up one of these snowball microphones.
It records great. Audacity is the perfect app for it.

The problem is that I can’t monitor the microphone’s input through headphones using my on board soundcard… Is this a known issue with crappy onboard sound cards while using USB inputs?

Maybe its time to cough up the cash for a usb soundcard?

Thanks for any input on this one.


The sound card won’t make much odds. The main point is that with a USB input device, you will only be able to hear the input signal via software playthough (Audio I/O tab of the preferences), but this isn’t normally recommended because of the latency (delay) it will add to the signal.

Found this “solution” for dealing with monitoring a USB mic without latency:

The only problem that I am facing is latency issues. (Not being able to listen while recording). But there is a simple fix; just place that hand over you ear, aim your palm toward your mouth while you announce a low-tech solution!