Slight distortion when mixing 2 tracks?!

Hi… I’m using Audacity 2.0.3, Windows XP, Realtek HD Audio soundcard with updated drivers. The problem is that when i’m mixing (playing) 2 tracks together it starts to distort and it has nothing to do with to much input level because i’ve tried to record with very low level and it distorts anyway?! Mainly the kick drum.
I always start with a ready drumtrack and then i apply a bassguitar track and then more tracks (more instruments) on top of that. I record thru an amp and then the mic input on the computer.
I used Audacity 1.3 Beta (Unicode) in the same way before and it always worked perfectly after my standards. I’ve mixed up to ten tracks together with the 1.3 Beta version before and it sounded OK!
What’s wrong?

Watch the playback meter ( while you are playing the 2 tracks together. Does the meter hit 0 dB? Does the “clip indicator” turn red?

Mixing is done by summing (adding) the samples together… Generally, you need to reduce the levels before mixing, or after mixing and before saving. (Audacity uses floating-point and can go over 0dB internally, but most file formats cannot, and your digital-to-analog converter cannot.)

No it doesn’t.

I’m not shore what you mean? (I’m fr sweden).

He means that Audacity uses “floating point” audio data by default, as denoted by the tracks saying “32-bit float”. If they say that, then Audacity can represent and store audio samples correctly even if they are above the clipping level of 0 dB. If so, it’s possible to postpone reducing the combined level of the tracks to below 0 dB until you export them to an audio file.

Is this the problem? Is the mic input able to take the high input level of the amp without cutting off the tops of the waveform, even if the level is below 0 dB?

And is the kick drum recording distorted if you play it on its own?

I suggest you adjust the mix levels so that it does not cause the recording meter clip indication to come on, then export a few seconds of mix as WAV so we can hear it. Please see for how to make and attach an audio sample.


Mic-In on a Windows laptop is very delicate and overloads very easily producing popping and cracking in the track – even if you reduce the sound level to avoid overload.

Oh, and the connection is usually mono, not stereo. It’s designed to do this, and pretty much only this:

To record your music system in stereo and without overloading, we recommend one of the Behringer devices such as the UCA202.


The thing is… when i play tracks separately on their own so to speak, it sounds just fine but when i play or mix them together it’s starts to distort?
Ok ill try to send a small audio sample… cool :slight_smile:

I have an ordinary pc not a laptop and i’ve tried ‘‘The T-bone HD Audio’’ but then the whole computer went quet.

So you have one of these:

If you don’t have a Blaster or one of the other common soundcard types, you’ll need to install software drivers (usually from the maker) or your computer may have no idea how to run it.

What is that?

I assume T-Bone are headphones but if so I don’t see what that has to do with it. We’re not disputing you hear distortion on combined tracks. I for one question plugging an amplifier into a mic port which is what you said. It could create problems that are only audible when combining the tracks.

Does this computer have a blue line-in? Is there a switch or software control to change the mic input to line level?


No it’s not headphones… Chek it out!

It’s the same problem when i use line in?! And why did it work perfectly with Audacity 1.3.1 and not with Audacity 2.0.3?? I’m thinking about to go back to the old version!

PS. Sorry about that it taking so long between my responds. But i’m very greatful for your answers! DS.

If it is the same Audacity project and you are using exactly the same equipment then there should be no difference whether you use 1.3.1 or 2.0.3. If it is a different Audacity project and/or different equipment then the difference could be due to anything that is not identical to when you used Audacity previously.

So that we can try to help you, please adjust the mix levels so that it does not cause the recording meter clip indication to come on, then export a few seconds of mix as WAV so we can hear it. Please see for how to make and attach an audio sample.

If there is a problem with corrupted audio in the drum track this could be similar to the unexplained distortion on mixing that some people have complained about on OS X.

At Edit > Preferences: Quality, make sure Dither under High-quality conversion (the bottom combo box) is set to some choice other than none. If you then export as WAV is there distortion in the exported WAV file?