Sliding Time Scale issues... Ubuntu 12.04, Audacity 2.0.0


I’m running Ubuntu 12.04 and Audacity 2.0.0. I installed it from Ubuntu Software Center. I also downloaded some plugins from the Ubuntu Software Center.

Anyway, my problem is that I’m trying to use the Sliding Time Scale to speed something up. I tried with the normal “Change Tempo,” but there was a lot of distortion. When I use the Sliding Time Scale, though, it turns it into garbage like I have never heard before. I’m including an attachment. I’ll show you the original, then with the sliding time scale. I didn’t touch the pitch, just the tempo; I put 20% in for both of them. I tried it with only 5%, even, and it did the same thing.

(I’m trying to make a CD for my parents for Christmas, but I kept making mistakes when I played it full speed, so I figured I’d play it a little bit slower and speed it up on audacity, haha.)

Ah, this rings a bell - I’ll need to check…

[Some time later] Are you using 64 bit Ubuntu?
There was a serious sound quality problem with Sliding Time Scale / Pitch Shift on 64 bit Linux. The problem was fixed about a year ago.

If this is the problem then there are a number of possible solutions:
If you have access to a Windows or Mac computer you could run the current Audacity 2.0.5 on there.
There is an Ubuntu PPA with “Nightly” versions of Audacity.
If you have a Windows installation disk you could install Windows as a virtual machine and run the Windows version of Audacity.
You could build the current version of Audacity from the source code (probably the best solution and less difficult than it might sound - in fact rather easy on Debian/Ubuntu based operating systems).

Alternatively, if you don’t mind a change in pitch you could use the “Change Speed” effect.

I was writing as Steve wrote, but I agree this is probably the 64-bit playback bug in Sliding Time Scale.

Just to add - if you use the Ubuntu PPA “daily” build which is based on the latest Audacity code, be sure to uninstall Audacity 2.0.0 first (assuming you are using the Ubuntu 2.0.0 package of Audacity). There is still a “Precise” (for Ubuntu 12.04) version of their latest “daily build” of Audacity so hopefully when you install you should receive that one. Here is the URL .


Yep, I’m using 64-bit Ubuntu. Thanks for all of the solutions you two - I appreciate the help! I think I’ll try one of those “daily” builds. :slight_smile:

To install the “daily” build requires adding the PPA to your sources list.
Because this PPA usually updates every day, it can be tiresome to keep updating, and occasionally (because it is the daily snapshot) there may be unexpected bugs. I’m currently using today’s code and it;s working fine. Unless you want to be involved in testing (you are most welcome to do so) you may want to comment out / disable the PPA source after you have installed to avoid being prompted to update every day.

As Gale wrote - be sure to uninstall Audacity before you add the PPA.

Hello again,

So I just installed audacity from that “daily” build, after uninstalling audacity 2.0.0, and it gave me the same problem with the Sliding Time Scale. So I think I’ll just have to pull out my old Windows laptop.

Thanks for all of your help, though!

I think the problem may be with the SBSMS (time stretch) library that the effect uses. The Audacity source code includes a fairly recent version, but the PPA build may use the repository version. The issue was discussed on the Audacity developers mailing list a year and a bit ago:

Using Windows will probably be your quickest solution, but once you have the immediate job out of the way, if you want to fix it on your Ubuntu machine. let us know - I think it should be quite easy to build Audacity with the correct version of SBSMS.