Skipping on playback

I just upgraded to Audacity 2.0.5 from 2.0.3 and no longer have smooth, uninterrupted playback. It is continuously jumpy (sounds like a stuck CD). I am using a late 2013 Macbook Pro (10.9.1). The exported .wav file is fine, but cannot listen to .aup file in Audacity editor without skipping. (I uninstalled and then re-installed Audacity (.dmg), with no change). This occurs whether the source is the laptop’s audio output (through Soundflower), or the built-in mic.

We can’t reproduce this problem on our machines so there is probably little we can do about it in the near future, sorry.

There are many things you can try, as given elsewhere on this board.

Try a Mac other than MacBook Pro.

If you have installed Mavericks over previous OS X, try reinstalling Mavericks.

If you are using a Firewire or USB playback device, try the built-in audio instead.

Use factory Audacity settings by resetting Preferences, thus. Audacity > Quit Audacity. Open Finder, Go > Go to Folder and type:

~/Library/Application Support/audacity/

Open audacity.cfg. Select all the text and delete it. Then type the following at the top of the file:


Save audacity.cfg and restart Audacity.

If that does not help, try Audacity > Preferences, choose “Recording” on the left. Try different “Audio to buffer” settings.

Try the latest 2.0.6-alpha from the top of . This has one fix that may be relevant. Try it and let us know if it makes any difference.


Gale, thanks for all the suggestions. I tried most (except finding another Mac or re-installing Mavericks, since 2.0.3. had worked just fine with it), including reverting to factory settings and installing Audacity 2.0.6. So far, no change.

Thanks for testing.

Another user of a Saffire Pro 40 interface told me that QuickTime had the same problem after installing Mavericks and that he corrected it by installing a Saffire Control Panel.

He said he could stop the Audacity playback stutter by opening System Preferences > Sound while Audacity was playing and selecting the Input tab. Does that work for you?


No such luck. Still skipping. Incidentally, I installed 2.0.5. on my old Macbook (OSX 10.6), and the same problem occurs.

Yes I know this or a related problem may occur other than on MacBook Pro - but it is most prevalent on MacBook pro.

Are you using a standard project rate - 44100 Hz or 48000 Hz?

I could probably build 2.0.5 with the PortAudio version that came with 2.0.3 if you definitely want to try it. It would prove if the PortAudio version is responsible.


Hi Gale,
I’m using 44100. As to the PortAudio version, I haven’t the slightest idea what that means. But I’m willing to be a guinea pig.

Hi again, Gale,
I updated my OS to 10.9.2 yesterday and that seems to have corrected much, but not all, of the problem. There is still some clicking and minor skipping, but not nearly as bad as it was. Thought you’d want to know.
Many thanks,

Thanks, Viktor. It will be interesting to hear if others have the same experience.

I am hoping 10.9.2 will cure the frequent (brief) beachballs that I see when doing almost anything on my Mac Mini. That was not an issue on 10.7 or 10.8.

If I make an Audacity build with older PortAudio (snaphsot r1554, the version Audacity 2.0.3 used) I’ll post here.


I have been plagued off and on as well by the skipping on playback (2.0.4 on OSX 10.8.5). I just tried your trick about System Preferences → Sound → Input tab. Problem solved. Thanks!

Thanks. Could you please tell us was this with a Saffire Pro interface, or some other audio device?