Skipping in Mavericks

I was using Audacity 2.03 and OS X 10.7. Things worked reasonably well. Occasionally, I would think I heard a small skip in play back. I was never able to be sure whether it was real. No skips showed up when exported to iTunes and converted to AAC format.

I upgraded to OS X 10.9 (Mavericks) and I started having lots of little skips. They would not repeat in the same place when I would replay the same spot and do not show up in iTunes. This is strictly a playback phenomenon in Audacity. So I upgraded to Audacity 2.05, and found no change. I increased the buffer size from 100ms to 200 ms. No change. Per other posts here, I changed my MIDI settings to 32 bit float, to match my Audacity settings. Now I get one large skip every once in a while, as apposed to many tiny skips. This is an improvement in that it is infrequent and it is so distinguishable, I know to ignore it. However, I would like it to be gone.

I’m using internal A2D and D2A converters on my iMac.

I’m using internal A2D and D2A converters on my iMac.

In other words, Headphone Out and Stereo Line-In.


You inadvertently encountered an alternate troubleshooting technique. Can you make it worse or change it? Answer: Yes.

Describe how you’re listening. Built-in iMac speakers? Headphones? External sound system? USB sound device?

Guess at the number of seconds in the gap and the approximate spacing.

Audacity > Preferences > Devices > Playback: Built-In Output.
That’s what mine says. What’s yours?

Go > Utilities > Activity Monitor > Title CPU > view: My Processes.
Import or load any stereo audio show into Audacity and set it to continuous play, Shift-SpaceBar. Bring Activity Monitor to the front and make sure it says My Processes. Click the %CPU column.

Capture the Monitor Window, Shift-Command-4 and draw a box around the window. Post the picture here. Enclosed is what mine looks like. Yes it’s unusual. I had a zip process crash and it left “ditto” pounding 99% of one processor. Note that Audacity is playing my clip with 18% of one processor (yours will not look exactly like this).

We’ve been looking for someone who can reliably get it to break so we can figure out what’s gone wrong. Are you up for this? You have to promise if you accidentally fix it, you post what you did.

Koz

Could try increasing the priority of Audacity so it is not interrupted …

Mac OS X users can use the Terminal’s “renice” command. Lowering the “nice” level of Audacity will raise its priority if the priority of other devices is unchanged. The default nice level for most applications is 0, in a range between –20 (highest priority) and +20 (lowest priority). To change Audacity’s nice value, type <sudo renice {nice #} {pid}>, where {nice #} is the nice level and {pid} is the process ID number of Audacity. You can determine a process pid with the “top” command or from ProcessViewer.

We don’t know it’s an interruption yet. If it was a simple interruption it would not have changed when the bit depth changed. I think that’s the best clue we have so far. I’m sad that the Activity Monitor display won’t fit on one screen in Mavericks like it does in Mountain Lion.

Koz

This won’t make it easier for you, but other users suggest that Audacity 2.0.3 (note the correct number) does not have the variety of playback problems that 2.0.5 has (mostly on MacBook Pro).

Is yours a MacBook Pro?

Perverse as it seems, also try reducing the buffer. Try 40 ms or 50 ms. That has fixed “crackling” on some machines.

Also note that several users had various problems updating to Mavericks but solved them by reinstalling Mavericks.


Gale

BTW: I am running on a 2 year old iMac with 8GB memory and 800gB free disc space.

Koz- to answer your questions.

In other words, Headphone Out and Stereo Line-In.

Yes, exactly.

You inadvertently encountered an alternate troubleshooting technique. Can you make it worse or change it? Answer: Yes.

The MIDI thing may have been a red herring. I’m now back to lots of small skips.

Describe how you’re listening. Built-in iMac speakers? Headphones? External sound system? USB sound device?

Mostly headphones plugged into the headphone jack because I can hear what I’m editing best this way.

Guess at the number of seconds in the gap and the approximate spacing.

They generally sound like the length of a pop from a vinyl recording, sometimes a little longer. One time substantially longer. At first I thought it was an artifact from “Click Repair”, but on replay there is nothing there.

Audacity > Preferences > Devices > Playback: Built-In Output.
That’s what mine says. What’s yours?

Yup, that’s what mine says.

Go > Utilities > Activity Monitor > Title CPU > view: My Processes.
Import or load any stereo audio show into Audacity and set it to continuous play, Shift-SpaceBar. Bring Activity Monitor to the front and make sure it says My Processes. Click the %CPU column.

Capture the Monitor Window, Shift-Command-4 and draw a box around the window. Post the picture here. Enclosed is what mine looks like. Yes it’s unusual. I had a zip process crash and it left “ditto” pounding 99% of one processor. Note that Audacity is playing my clip with 18% of one processor (yours will not look exactly like this).

See attachment.

We’ve been looking for someone who can reliably get it to break so we can figure out what’s gone wrong. Are you up for this? You have to promise if you accidentally fix it, you post what you did.

I get it pretty reliably. So here’s my latest data point. I just loaded my last transcription to get the screen capture of the Activity Monitor, and it has not skipped at all. When I played it back after immediately recording it, it was chock full of skips. There may be something related to the amount data in memory, playback following a recording, … I will have to investigate this further, trying different process sequences. I’ll also try to capture the activity monitor when it’s actually skipping.

I am aware some people have had success reloading Mavericks. Since that is a 3-4 hour process, it will have to wait for a snow day.

I tried 50 msec buffer size. No difference.

Apparently, the system can’t handle a Tagged Image File Format (TIFF) graphic. Try JPEG, GIF, or PNG.

Koz

So that begs the question, what’s different in the memory management between 2.0.3 and 2.0.5? Time to escalate this to the developers?

I know from other investigations that Mavericks has different management than other Macs and further, may have “special” power saving techniques for longer battery life.

DigiVinyl

Apple (upper left) > System Preferences > Power Saving. Does yours look like mine (attached)?

Koz

I know chances of this are zero, but do you have any way to record the skipping? Cellphone Personal Recorder APP?

Koz

Nothing to my knowledge. If memory leaks are found, they are fixed.

There is some new “memory compression” technique in Mavericks that I think is responsible for the numerous short beachballs that occur in just about any app.

But some people have stuttering playback in OS X 10.5 and 10.6 and many of those are MacBook Pro.

If the version number is reported correctly, occasionally 2.0.3 is said to be as badly affected as 2.0.5.


Gale

Audacity can record itself using Soundflower ( Audacity Manual ) but it’s possible that may cause extra stuttering.


Gale

Here is a screen shot of the activity monitor while skipping:
Screen Capture2.png
s:

Here is a screen shot of my power settings:
Screen Capture3.png
I’ll see what I can do about recording a sample. Mostly its sounding like pops and clicks from vinyl records, which is disconcerting, since that is what I’m recording. But of course, they’re not, because they move to other places on replay and go away on the exported file. Then at rare times I’ve heard them up to a few tenths of a second long, a momentary drop out.

The CPU use shown in DigiVinyl’s screenshot while playing is equivalent to mine in Mavericks (I don’t get stuttering, crackling or skipping).

The large number of “Idle Wakeups” for Audacity is interesting, even when Audacity is notionally “idle”. This value (new in Mavericks) shows as I understand it the number of times a timer fired in the app in the last second. I get between 140 and 230 Idle Wakeups pre second when playing.


Gale

I have a new clue. I was going to record an example of what is happening by using a loopback cable to feed my iMac output to the input and put Audacity in overdub mode.

I tested to make sure I was having the problem and then turned on overdub without plugging in the loopback cable. I had never used overdub before and wanted to make sure I was doing it right so I wanted to hear the playback. The problem went away. I took it out of overdub mode, deleted the overdub track, and the problem was back (cracking, skipping, etc). I then repeated the sequence and it did exactly the same thing.

Thanks for testing. What input were you recording from? Built-in audio line-in?

And if you leave overdub enabled (it is on by default) but just play the track without recording it, do you hear the skipping?

Have you updated to 10.9.2 yet? Does it help?


Gale

Thanks for testing. What input were you recording from? Built-in audio line-in?

Yes, built in audio line in.

And if you leave overdub enabled (it is on by default) but just play the track without recording it, do you hear the skipping?

Yes, but it doesn’t seem to be quite as severe. The randomness of it makes it a little hard to judge.

Have you updated to 10.9.2 yet? Does it help?

Yes. 10.9.2 behaves no differently, as far as I can tell.

Playing while recording is much more demanding than just playing.

Again it seems that Audacity needs a more demanding setting.

Try “Audio to buffer” again in the Recording Preferences. Set it to 5 ms. It will probably fail to play. Take it upwards in 5 ms increments from there.

You could even try adding an extra layer of routing by installing Soundflower ( http://code.google.com/p/soundflower/downloads/list ) then set the Audacity playback device to Soundflower, with Soundflowerbed turned on .


Gale

OK. I brought my MacBook Pro (10.8.2) on-line with Audacity 2.0.5 in a conventional install. Generate > Tone. I don’t see (or hear) any stuttering, snapping or any other bad playback.

I wondered what those flash beach balls were. They don’t animate which is a little odd. The up side is apparently an increase in battery life. I have to work on batteries for part of the day and the % battery left is higher now than it was.

Koz

Are you an administrator on your machine?
Apple (upper left) > System Preferences > System > Accounts > Koz: Allow User to administer this computer.

Did you upgrade to Mavericks or buy the machine that way? There is a “garden faerie” thing that happens in Mavericks. During changes in pointing, clicking or opening or closing programs, you will see a very brief flash of Spinning Beach Ball of Death. It’s not spinning and it’s only there for a split second. I’m considering leaving sweets out to coax it out of hiding for longer periods. I was just starting to worry about break-ins or some other system problem, but apparently, that’s normal, as is the new, non-animated Time Machine icon.

What’s not normal is this snapping thing.

You’re not using Audacity from inside the installer drive are you? You actually installed Audacity by dragging the Audacity program folder into the Applications folder and then trashed the installer drive?

Do you have playback problems with any other application? Do you like to watch TED talks or YouTube cat videos with sound? Your iTunes collection of Polka Classics?

I’m trying to think of what could cause OS-X to not realize that Audacity is requesting services.

Koz

How much memory and are your drives internal? How full?
Koz