Skipping Areas Between Clips?


If I have two clips on a single track, separated by an empty area (i.e. not containing any audio), is there a way to play the two clips but skip over the empty area?

I’ve tried using Cut Preview but this only seems to work for individual clips.



Cut Preview (shortcut key “C”) should work, but you need to select the white-space (empty area).

Hmmm…this doesn’t seem to be working properly. I created two five-second noise clips separated by one second of nothing. I’ve got Cut Preview set to two seconds pre and post the edit. If I select the empty section of the track the pre section plays properly, and the cursor skips the empty section, however it doesn’t start playing the post section. Instead it only plays the last second of the audio.

Have I done something wrong here or is this a bug?

It’s working correctly on my machine.

What sort of Mac are you on?
Which version of OS X?
Which (exact) version of Audacity (look in “Audacity > About Audacity” for the full version number).

I’m using a MacBook (7.1, Core 2 Duo) running OSX 10.9.5 and using Audacity 2.0.5.

MBP 15" 2.6GHz Core i7, 8GB memory, 250GB SSD.
OS-X 10.9.5, Audacity 2.0.5

See attached. My preview plays from 3 to 8 and skips over the 5-6 selection.

How did you get the one second hole? I created the two clips and Time Shift Tooled the second one to the right.

Screen Shot 2014-09-26 at 6.31.08 PM.png

What I did was - create eight seconds on noise, split it at four seconds and then Time Shift the second part one second later.

Another strange thing - if I increase the gap to two seconds and then select it, I don’t get any audio playback post cut.

I did what you did and mine plays two to seven, skip four through five. Attach 1.
Then I expanded the gap to two seconds. The new one plays two through eight, skip four through six. Attach 2.

Are you using the “C” shortcut key to play?
If you don’t split or shift, just create eight seconds of noise, does that play beginning to end?

Are you using 44100, 32-floating for the digital standard (left of the track).

Does it still do that if you restart the machine and start with fresh everything?

Screen Shot 2014-09-27 at 10.20.57 AM.png
Screen Shot 2014-09-27 at 10.16.50 AM.png

Yes, I’m using the “C” key. Normal playback is fine. And yes, the project is 44100 and 32-bit.

I haven’t tried a machine restart so I’ll give that a go and see.

It’s not likely to be that, but it’s not that unusual for a machine restart to cure a “magic” performance issue. It’s the go-to suggestion when the poster presents a problem that doesn’t fall into other, more common possibilities.


I’ve tried a restart but it didn’t make any difference.

Here’s a clip showing the problem. Sorry it’s a bit rough!

Try switch off “Snap To”. Does that make a difference?

What settings do you have in “Edit > Preferences > Recording > Latency” ?

The “Snap To” setting doesn’t make any difference.

Audio to buffer is set to 100 ms

Latency correction is set to -130 ms.

What seems to be happening is that the gap between the two clips is determining when playback starts after the selection.

Have you tried quit Audacity, initialising audacity.cfg then restart Audacity: Where are Preferences stored ?