"Single Band Parametric" occasionally losing "Enable"

I’m using Audacity 2.1.0 on Vista Home Premium (64 bit system), and single_para_1203.dll is dated 9/25/2006.

When I updated to Audacity 2.1.0 I got some happy surprises with this plugin - resizable window, user presets, and the “Enable” switch that required a look at the manual to figure out. I especially appreciate that the Spectrum cursor remains active now while the effect is open. All very handy especially when I use the plugin for a frequency probe to identify the offending spectral line for filtering, and especially when tracking the whine from a variable-speed projector fan. I keep the effect window open so I don’t lose the most recent setting, and enable it when I need it.

OK, now the problem: Occasionally the plugin behaves as though Enable is not ticked. I can still apply the effect, but I can’t preview it nor does it function during play even though the Enable box is ticked. The only way to restore normal operation seems to be restarting Audacity. I have not been able to identify a trigger for this phenomenon - it just seems to happen after using it this way for a while. In the course of this I use Analyze->Plot Spectrum frequently, and often have that window and Single Band Parametric open simultaneously.

Do I need to update the dll, or go to Audacity 2.1.1, or both, or is this a hitherto unknown issue?

I intermittently get those problems too on 2.1.1, in range of VST plugins , (old & new).
The problems appeared with the introduction of real-time adjustment of effects: Audacity (2.x.x) .

Problem#1, in real-time preview, the effect behaviour doesn’t correspond with the control settings shown , ( apparently sometimes the changes in control settings aren’t being updated ). Stopping then restarting playback sometimes cures Problem #1: the effect applied then matches the control settings shown.

Problem#2, checking or unchecking the enable tick-box during playback can cause that effect plugin to become completely disabled in real time preview, but effect can still be applied. Problem#2 only fixable by restarting Audacity. ( also occasionally Audacity will crash when the effect enable tick-box is checked or unchecked when the track is playing ).

That may be fixed or improved now. Have you tried 2.1.2 RC1 from http://www.fosshub.com/Audacity.html?

What effects does that apply to apart from possibly “single_para_1203.dll” which is a LADSPA effect? Are they VST’s?


I’ve experienced problem#2 , (which is consistent with DickN’s description), in Audacity 2.1.1 on Windows Vista, with a number of VSTs from different manufacturers. The fault is intermittent, I’m guessing 1 time in 50 the VST will be stuck-disabled in real-time preview after checking or unchecking the the enable tick-box while the track is playing. Restarting Audacity is required for that particular VST to work normally again, the stuck-disabled VST can still be applied to the audio but there is no way previewing the effect. ( other VSTs will still work OK even though one is stuck-disabled ).

The only circumstance which may be a trigger for the fault, is rapidly & repeatedly checking-then-unchecking the enable tick-box while the track is playing.

How can I identify a VST effect? This is the only effect with which I’ve had the problem, but it’s also the only one I’ve used so far which has received these new features.

I also toggle Enable rapidly because I’m sampling short pieces of what should be silence and listening for changes in background noise components. In particular, I often turn Enable on or off very shortly after starting playback, which is usually via the button on the effect panel because with focus on this panel it intercepts the spacebar.

Will try 2.1.2.


If you use 2.1.1 or 2.1.2, all effects should have a “Manage” button. “About” in that Manage menu tells you the type of effect.

All that sounds like Trebor’s second problem, but I am not sure that 2.1.2 may contain anything to fix that, only (perhaps) his first problem.


I assume that is Windows XP? I don’t get a crash on Windows 10 in 2.1.2 RC1 with Marvel GEQ (I’ve not tried other Windows yet).

I do get the crash in 2.1.1 but it is very rare, I cannot produce it to order and have to click faster in the Enable box than it would be possible to hear the difference (even faster than Trebor was clicking).

In 2.1.1 or 2.1.2 RC1 with the “Single Band Parametric” or Marvel GEQ I don’t get any failure of Enable to play the filtered sound.

Perhaps you could both try 2.1.2 RC1.


Just tried 2.1.2 RC1 (installed from the zip). None of the built-in effects are in the menu, but the installed effects are! What did I do wrong? I’m using Vista home premium, 64 bit.

I tried downloading 2.1.1 (installer) and installing 2.1.1 that way. Still no built-in effects in the menu, but “Manage” at the top. Tried Manage, and all the built-in effects were already enabled. Clicked OK, and viola! There they were in the menu. I closed Audacity 2.1.1, clicked the icon for 2.1.2 RC1, and now the built-in effects were present in that one too.

Since I’ve already set 2.1.1 as the default program for .aup files and Gale says he doesn’t get any Enable failure with either 2.1.1 or 2.1.2 I’ll try this setup for a while unless I’m asked test 2.1.2 RC1 first.

Could it be because I have multiple versions installed that the built-in effects had disappeared?

OK, I’m switching default program to 2.1.2 RC1. ‘B’ (play to selection) and ‘C’ (cut preview) aren’t working in my installation of 2.1.1.

No, it’s Windows Vista with aero-glass display turned off.

My typical toggling speed would be every few seconds, that rate too can also cause Audacity to crash,
i.e. toggling “Enable” several times per second is not necessary for crash, it just happens quicker that way to create a brief demonstration video. Particularly annoying is restarting Audacity after a crash, and employing the same VST which crashed it , clicking enable once on that VST can cause a second crash , ( the air turns blue at that point ).

When I tried 2.1.1 (before I discovered “B” and “C” not working), Single Band Parametric initially had Enable checked but it was not enabled. This was the initial condition before toggling the state. It remained disabled until I restarted Audacity. I cannot say whether this was before or after I found the built-in effects missing from the menu and got them back by clicking Manage and then OK.

I’m using 2.1.2 RC1 now and haven’t had any problems yet but will have more confidence by the middle of next week. I did notice a display anomaly: When scrolling the display vertically it’s possible to get the vertical scale of the top audio track overlaid upon itself with an offset. It recovers when scrolled out of that position.

OK, but please try 2.1.2 RC1 assuming you have not done so. We are not going back to fix 2.1.1.


Please give us more steps if you can. Number of tracks, if the vertical display is zoomed, exactly how you are scrolling vertically.


I’ve occasionally seen similar when switching from 2.1.1 to 2.1.2-alpha. I can’t figure what is happening or see anything obviously wrong in pluginregistry.cfg, but I have added http://bugzilla.audacityteam.org/show_bug.cgi?id=1287 as a precaution.

If 2.1.2 RC1 fails to display built-in effects again, could you attach pluginregistry.cfg before running Effect > Add / Remove Plug-ins… in 2.1.2 (just in case your file shows anything).

By the way, I am male.


Just tried 2.1.2 RC1 for about 30 minutes , occasionally enabling VSTs will cause Audacity to crash, as with 2.1.1

Oddly dblue Glitch V1.3 VST works in Audacity 2.1.1 , but not at all in Audacity 2.1.2 RC1 ,
and some mda VSTs work normally with Audacity 2.1.2 RC1 , but are stuck on default settings in Audacity 2.1.1 .

It’s a bit elusive. When in this state, shrinking the Audacity window vertically can black out both the TCP and the vertical scale, but these return when size is expanded again. Zoom is normal (-1 to +1). Seems to require the track to be expanded vertically so it doesn’t all fit the available space, but that’s not a sufficient condition. It seems to happen only when the bottom of the scale is near the top of the track window. I have gotten it to happen with the top track expanded (not zoomed) almost to the point where the tic mark interval changes from 0.5 to 0.1, which might be a necessary condition. Next time I reproduce it I’ll try to make an .aup file with no waveblocks to send you. It may also be dependent on the display resolution. My display adapter is NVIDIA GeForce 6150SE nForce 430. I’ve been using the scroll bar to scroll but I think it happens using the scroll wheel also. Just trying to produce the anomaly with a new project (no audio), I have gotten it with one stereo track and a label track below it, but the next time I try it doesn’t happen, which is why I think sending you an .aup file is the best way to go. The window size is in there too, right?

Currently working on a project, somehow have 2.1.2 RC1 in a state such that typing in a focused label track won’t make a new range label, but will still make a new point label if no range is selected. Ctrl-B still works.

Also: Single Band Parametric is now stuck in the “no enable” state.

Restarting Audacity restored Enable for this effect, and the frequency and gain settings (I’d applied the effect once for test purposes but I’m using it as an analysis tool) were retained but BW wasn’t.

Still doesn’t create a new range label when I type into a focused label track. Hard to believe 2.1.2 RC1 was like that all along and I just discovered it now, but could be. I was using a couple of versions yesterday and I started this project on the laptop using 2.1.0.

Another off-topic comment: Single Band Parametric’s usefulness as a tool dropped a little due to Frequency setting getting limited to integers. It might sound picky, but when the needed center frequency of a notch is say, 57.3 Hz (a common one for induction motor noise), that fraction gets important to find.

The AUP file stores the track height as it was when you last made a change to the project state.

The size of the Audacity window is stored in audacity.cfg.

It’s probably intentional if you already have a region label of the same width. You won’t be able to type to create a second point label at the same place either. The idea is that this might be easier to use keyboard playback commands without having to move focus out of the label track.

Please start a new topic if you want to discuss that.

Do you mean “Bandwidth (octaves)”? Having changed from one Audacity version to another I wasn’t seeing any non-default settings in that effect restored after restarting 2.1.2. But after I deleted pluginsettings.cfg then non-default effect settings were restored.

So try deleting that pluginsettings.cfg. Note that you have to apply the effect to save settings changes.

This changed in 2.1.0, right? I don’t know why that happened. Do you get your desired audible effect if you set the desired decimal point value in pluginsettings.cfg?


Yep, that’s what happened. Historic note: I long ago disabled all the keyboard shortcuts that don’t involve Ctrl or Alt which could bite me in Record or Playback. Back in the 1.x days there were some real gotchas.

That seems to have fixed it - Thanks! I had applied the effect, but Bandwidth (octaves) was not saved. Now it is.

Yes, same issue on my laptop and it has 2.1.0.

No, the effect on a test tone is exactly the same as if frequency is set to the nearest integer, and that integer value gets saved with 12 zeros after the point in pluginsettings.cfg.

Man, that base64 code in pluginsettings.cfg is cryptic when looking for an effect. If a couple of effects have parameters with the same names, woah! My first try at this test was before I’d deleted the file. I tried to create a new user preset by copying an existing one and editing the numbers and the name. Somehow I managed to get Single Band Parametric to not be able to read any of my presets although it could find the names.