Silent lead-in when copy/pasting [SOLVED]

This is driving me mad, but I’m trying to loop a single bass kick. I zoom right in on the sound and trim it at the very second the wave form moves from the line, then do the same at the back. But then when I copy & paste the sound, the copy always has a short lead-in of silence. Is this a default or something, as I have no idea where it’s getting this lead-in from, as it’s not there on the section I’m copying?

I know there are other and better ways to loop a sound, but I have my reasons for doing like this, so if you could please just humour me I’d appreciate it.

I’m not the best person to answer because I don’t make loops, but since no one has chimed-in yet…

I’d make a short [u]crossfade[/u]. You can make the crossfade very short (milliseconds) so it’s not noticeable, or you can make it a little longer, or you could make the fade-out longer than the fade-in, etc. depending on how you like it. If you wanted to loop it 100 times (or more) that could get tedious but you could “loop the loop” and double it every time to make it more manageable.

…I don’t know much about this either, but [u]FL Studio[/u] “evolved” from an older program called “Fruity Loops”, so I assume it’s still very good for making loops. (It’s not free.)

Although you have not said so, I’m guessing that exporting to an MP3 file is involved somewhere in your workflow as that would explain the problem that you describe.

Copy and paste within Audacity is exact. If you copy 4001 samples and paste, then 4001 samples are pasted (no added lead-in or lead-out).
If you export audio from Audacity to create an audio file, then the exported file may not be an exact copy, because it is subject to the limitations of the file format. For example, MP3 files always have a bit of padding at the start.

Problem solved

It seems when you butt a sound file up to the very start, it ‘sinks’ any silence behind the left-hand panel. So that when I highlighted, I was also grabbing this hidden part too. How I missed it during the trim is another matter, but just put this one down to me being a bone-head.

Thank you both for the answers.

@DVDdoug, thank you for the tips, but getting a seamless loop isn’t really the issue here. I’ve had a detailed tutorial on doing this, provided for me in another thread. The way I’m trying to loop on this occasion is unorthodox to say the least, but as I say it is this mysterious lead-in of silence which is being copied from somewhere that’s puzzling me.

@steve, no exporting/importing involved here. On this occasion I am using Aud’s record feature to capture the sound file, which I’m then trimming as required. I’m sure there’s no doubt a massive drop in quality, but when I can create an entire 3 min song for about 2.0 mb in this fashion, compared to downloading and importing a bunch of 5 second loops at approx 4.5 mb a time, then I’d rather do it this way.

So, just to reiterate, I record the sound, trim it front and back, then select the whole thing and ‘repeat’ X times. When I do this, each of the ‘pasted’ copies have something like a 1/4 lead-in of silence. It’s very odd.

The bite on the right is copied from the one on the left.


Arrows at the start of the track indicate there is audio before time=0.0

To see the exact time that is selected, look in the Selection Toolbar (

Because I don’t make loops, I’m not the best person to answer, but since no one else has…

I’d do a quick crossfade. Depending on how you like it, you can make the crossfade very short (milliseconds), or you can make it a bit longer, or you can make the fade-out longer than the fade-in, etc. If you wanted to loop it 100 times (or more), you could “loop the loop” and double the loop each time to make it more manageable.

I’m not sure what FL Studio is, but it “developed” from a previous program named “Fruity Loops”, so I guess it’s still extremely good for looping. (This isn’t a free service.)

Are you a bot?

The post you are responding to is over three years old. Also your post looks surprisingly similar to this post:

Also, this post was previously marked “SOLVED”