Silences during playback (record not involved!).


I’m using Audacity 3.1.3 on Windows 11.

I’m having an issue on one Audacity project and unsure if it is being caused by Audacity settings, computer settings, or ‘other’.

The issue I am having is that I am experiencing moments of complete silence during playback, they’re short and probably no more than a few tenths of a second to half a second. Where they happen is random, each playback results in the silences happening in different places. Every playback however I would say the silences happen around every 15 to 20 seconds, for the entire duration of the playback.

I haven’t used the record function of Audacity at all for this project, it is based on .wav files that were recorded on a Tascam 8-track studio and are fault free. I will get the possible ‘other’ out of the way right now! The project is currently comprised of 24 tracks, each one lasting 20 minutes. It’s a long song :slight_smile: It is in fact the entire reason why I recently started using Audacity, as my Tascam is just 8-tracks and I don’t want to use bouncedown for this song, I want to keep the whole thing at individual tracks. It was my intention to go up to around 48 tracks, but if this is the reason for the silences (number and length of tracks) then that isn’t going to happen sadly.

The song itself plays at the correct speed, none of the tracks are going out of sequence with the others, no other issues, just the annoying short silences.

Is it as simple as I’m trying to use too many tracks at too long a length for Audacity to handle? I would like to think my computer can handle the situation though, and the fact there are no other issues does suggest it isn’t at fault on a performance level.

I’d love to hear from anyone who has experience of using a lot of tracks/long songs with or without the issue I’m experiencing (or anyone using less and shorter tracks and experiencing the same) and hopefully how you fixed it.

I am living in hope there is a simple fix for this, I imagine Audacity is there for complex projects to be managed.

I have had a good search through the forum and manual, but all the topics or references in the manual refer to problems that have been caused when users have recorded tracks and are then suffering from issues during playback having used the record function. These are literally all imported tracks, I haven’t been anywhere near the record function or messed with any of the related settings, this is something Audacity is doing based on imported .wav files only.

Thanks for reading, I look forward to hopefully not just reading I have zero chance of ever getting this project to work without any problems!

I’m not sure what system info would be of use, but the basics are:

OS Name Microsoft Windows 11 Home
Version 10.0.22000 Build 22000
System Type x64-based PC
Processor Intel(R) Core™ i5-1035G1 CPU @ 1.00GHz, 1190 Mhz, 4 Core(s), 8 Logical Processor(s)
Installed Physical Memory (RAM) 8.00 GB
Total Virtual Memory 9.04 GB

Replying to myself here, and this is genuinely not just a bump-up, I have some more info that may help anyone who finds themselves in the same predicament as me.

Having only so far worked on this as an active project, I suddenly wondered to myself whether the issue of gaps/silences would still be present if I master the track. So I did, as an .mp3 at 320kpbs.

And the result: There are NO gaps/silence anywhere within the full 20 minutes of the song. :exclamation:

So, whatever causes this problem is strictly related to playback only.

It will still be a pain in the rear having to endure the frequent and constant silences while working on the project, but I at least know that the end product will sound how I want it to.

What “Project Rate” are you using?
(“Project Rate” is in the lower left corner of the main Audacity window)

I’m using 44100.

I haven’t adjusted any of the standard settings for this project.

That’s possible, though I’m surprised that it is struggling with 24 tracks. Given the specs of your computer I’d expect Audacity to be able to handle many more tracks. Perhaps something in your system is slowing Audacity down.

Audio data uses a lot of disk space, and Windows requires a reasonable amount of free space for background tasks. How much free disk space does your PC have (if you have multiple drives, please specify).

Have you tried rebooting the PC, then running Audacity with no other apps running?

You could also try temporarily disabling any virus checker / security products to see if that makes a difference (remember to turn them back on after testing). If this is the problem, then it may be necessary to white-list Audacity.

Perhaps also worth checking to see what background tasks are running (with the Windows “Task Manager”), and if any “start on boot” apps can be disabled so that your PC has more available resources.

Thanks for all the tips Steve.

In terms of physical disk space, it’s a 1TB laptop and I have 732GB of free space.

When I first bought the laptop a few months ago I did my usual of disabling as much as possible at ‘start on boot’ and when I’m due to use Audacity I never open any other programs after starting the laptop. I also have Windows Updates paused.

For security I just use the standard Windows tools, I never use third party anti-virus software for the exact reason that for the purposes I use a laptop for they slow the system down far too much to be of reasonable use. The risk/reward ratio just doesn’t balance for me. That said, I’ll give it a try disconnecting from the internet and disabling all the security features, then try Audacity and see if the problem still replicates.

Sorry - also meant to say, in terms of drives:

I do have a G drive showing, which doesn’t seem possible to access. I’m assuming this is some partition already in place when I set the laptop up. I’ve never even noticed until now.

I also have an ISO mounted on drive-D (the old Music 2000 program by Codemasters!)