Shifting a single highlighted part of a track [SOLVED]

I’ve never had this problem before but since a couple of days ago, audacity has been acting strangely and I don’t know the cause of it. When I have several mono tracks on a project and highlight a part in only one of them, for some reason it appears as if all of the tracks get selected (though the rest of the tracks get grayed out with clocks all over them.) I didn’t think too much of this but when I tried to use the time shift tool as I usually do, it shifts all of the tracks despite only a single one being highlighted. Same thing happens when I try to delete a specific part of a track. Only one bit is selected but it cuts away everything in that space of time in the project.

I have audacity 2.1.2 and have it installed on a windows 10 laptop.

You’ve accidentally enabled “Sync-Lock”.
Click the “clock” button to disable it.
For more information, see:

I don’t know how I did not notice that. Thank you ever so much.

No problem, glad you’re back up and running.