Severe playback distortion due to low buffer setting[SOLVED]

Audacity 2.0.3 on Win XP SP3 exe installer

Early August of 2012 Audacity started severely distorting all playback. Tried the FAQ, posted here and got several replies that didn’t help, tried Googling Web to see if this has cropped up anywhere else. No luck. Upgrading to newest version(s) has not helped nor has all tinkering with preferences and related settings. The only audio software that does this is Audacity.

Today I noticed something that might be a clue. The playback is not only distorted, but the tempo is slightly slower than any source material or Audacity-generated mp3/wav files. What might this new info mean?

Old post:

You don’t say you have chosen Windows Direct Sound, both Exclusive Mode boxes checked in Windows, chosen a sample rate that Delta supports and also used that rate for the Audacity project rate. So try that (and start by choosing 44100 Hz or 48000 Hz). Here is the link: .

Do you get the same problem if you choose your built-in motherboard sound device for playback?

Are you using stereo playback on the Delta?


Yes, Windows Direct Sound. I thought the Exclusive Mode boxes were only available in Win 7? The PC where I have the problem and do 99% of my work is XP. The Delta sound card supports sample rates from 8,000 to 96,000, although I stick to 44,100 in Audacity.

The only option available in the Windows sound control panel besides Delta is something called SoundMax, which I assume is what you’re describing. I tried choosing that in both the sound control panel and Audacity and got no sound at all, although the output bars were moving. (I notice Audacity has an option named Primary Sound Driver, but same distortion there.)

Yes, stereo playback in the Delta. I’m still stumped.

Yes. My mistake, I only skim read your other post and happened to notice Windows 7 mentioned for the file source. But speed changes usually indicate sample rate problems.

Can you think of something else relevant to audio that happened in August 2012 when the problem started? Did you install Skype or other audio programs?

Make sure Delta is set to 44100 Hz, then (I think Delta has a Control Panel in Windows, so look there).

Yes SoundMax is what I was suggesting you tried, if only as an experiment.

Microsoft Sound Mapper - Output (if you choose MME host) and Primary Sound Driver (if you choose Windows DirectSound host) are whatever you chose as the default playback device in Windows “Sounds and Audio Devices” in the Control Panel.

If you get no sound from SoundMax, obviously that is wrong for a start.

I read more carefully but making sure you have correct drivers for SoundMax and Delta doesn’t seem to have been mentioned.

For SoundMax, go to the computer or motherboard maker’s web site to look for audio drivers for SoundMax. See here for help .

For Delta drivers, try here .


Gale, I downloaded what looks like an updated Soundmax driver and will install tonight when I get home from work. My Delta driver is up to date, and yes it has a very detailed control panel.

I didn’t make any other audio changes in August. Only the new Delta sound card. It’s considered medium high-end which is what I need for home recording. What still surprises me is that all my other audio software works fine with the new card; only Audacity isn’t working right. A big problem since I need Audacity for my audio work. I have Reaper for mixing down tracks and adding effects, but it’s a huge pain for certain kinds of detail editing that is easier in Audacity.

One thing you mentioned was what I specify as the default device in the Windows control panel. I currently have all three defaults set to different parts of the Delta. There’s a stereo channel for playback, a MIDI channel, etc. I assume Audacity would be OK with that, and the left side drop down is set to DirectSound while the playback matches the playback option in the Windows control panel. (As mentioned before, testing the other options on these Audacity dropdowns didn’t fix this.)

Double-checked all drivers. Updated SoundMAX. Tried setting Windows control panel to use SoundMAX for everything, and set Audacity to use it as well, still no sound.

Reset everything to the Delta. Same distortion.

Do you have XP Media Center Edition? M-Audio devices do not support this: .

Can you open the Sound playback side of Sounds and Audio Devices

and post images of all the playback devices you have for M-Audio and SoundMax?

Audacity does not support multi-channel playback, only stereo.

When you say you have no sound from SoundMax, is this in Audacity, or is this in all programs - meaning, if you set SoundMax as default playback device in Windows, then play a file in Windows Media Player, can you hear any audio? If not, that isn’t an Audacity issue but equally there is no reason it should not be fixable.

If the problem is only in Audacity, do you get “error opening sound device” when you play back to SoundMax? Do you see activity on the playback meters?

There is still a possibility of exploring if older versions of Audacity will suit M-Audio better, but please have a check through the above questions.


If you export the work from the Audacity timeline, does it play OK in other programs?


Do you have a USB sound device you can listen to, such as a USB Gaming Headset, USB Headphones, a USB Recorder or maybe one of our favorite UCA202 devices?


I can answer some of this although I’m at work.

No, I’ve never had XP Media Center Edition.
I’m able to access Sound playback and all the other settings in Sounds and Audio Devices. I’ll gather images tonight.
Not sure what multi-channel playback is. The Delta sound card gives me output options with names like “1/2” which only means left/right channel for one normal stereo output.
SoundMAX works fine with anything but Audacity. Not even sure I want to worry about this problem, since I spent the extra money on the Delta card to get better performance than Intel’s mediocre technology. But yeah, it not playing may be a clue as to the larger problem. I’ve never seen any error message when attempting playback through SoundMAX. Yes, activity in the playback meters when attempting SoundMAX.

Everything I export from Audacity plays perfectly elsewhere. Mp3, wav, etc. The distortion is limited entirely to any attempt to play what I’m working on from Audacity itself. Plus, I can copy the aup and associated files to my Win7 64-bit PC at work, and playback from Audacity just fine. So, I don’t suspect any file corruption.
Don’t have any USB devices like that; would it be useful to run a test with one if I could borrow from a friend?

Here are screen capz of the three sections of the Windows sound control panel. Ignore virtual cable; it’s a week-old effort to attempt to route Audacity to the output via another route, and haven’t completed the experiment. The problem started long before it was installed. HTH.

What happens if you set the recording input to “M-Audio deleta 1010LT 1/2” ?

What is “M-Audio deleta 1010LT Mon Mixer” ?

I’ll have to test that setting and find out tonight.

Plus I’ll have to read the manual re the Monitor Mixer.

What happens if you set the recording input to “M-Audio Delta 1010LT 1/2” ?

No change.

What is “M-Audio Delta 1010LT Mon Mixer” ?

From the manual: “… a hardware digital audio mixer built into its PCI controller chip. It accepts digital audio streams from all hardware inputs and all outgoing software audio devices, mixes them with 36-bit internal precision and then provides the mixed output to one or more locations.”

For completeness, uncheck Overdub (on/off) and Software Playthrough (on/off) in the Audacity Transport Menu. Increase “Audio to buffer” in the Audacity Recording Preferences (it affects playback, too).

Otherwise I suggest you get the zip versions of Audacity 1.3.13, 1.3.8 and 1.2.6 here: .

Extract each zip to a different folder. Try each one. 1.3.8 and 1.3.13 each had newly updated versions of the third-party PortAudio Audio I/O interface which we use. I would not recommend 1.3.8 as it has lots of other bugs which had been fixed by 1.3.13.

1.2.6 is somewhat lighter and more responsive than 1.3.x and 2.0.x and of course much more contemporary with XP.

There are other experimental builds of the current Audacity code you could try. It is possible that a build supporting WDM-KS could help you (lower latency, bypasses the Windows Kernel Mixer, giving direct access to the audio drivers). DirectSound (supported in current Audacity) does that too (on XP, but not Vista and later), but WDM-KS is faster.


I will work on that tonight. Gale, thanks for sticking with me. I’ve been in other forums where helpers got distracted or lost interest. I very much need to solve this problem, partly because I pretty certain it’s going to turn out to have a simple solution, but more importantly if I have to switch to a different audio waveform editor, it’s going to cost me hundreds of dollars!


But not how I expected. I had resigned myself to using one of the older versions. Unzipped 1.3.13, launched it and while there looked at preferences. Overdub and Software Playthrough were already unchecked, as was the case in 2.0.3 where I had trouble. I did change the “Audio to buffer” setting from 25 to 75. Opened the most recent mp3 exported from my project, and Audacity 1.3.13 played it perfectly. Which I more or less expected. Closed the app.

Launched 2.0.3 and looked at three preferences just mentioned; they were already at the unchecked first two and altered third from my first test. I wondered if both version stored preferences in the same place? Opened the same file and Audacity played it perfectly. Surprised me. On a hunch, I started backing off on the “Audio to buffer” setting in increments of 10. No problem at 75, 65, 55 or 45. At 35 it was somewhat horrible, and at the original 25 it was horrible as usual. Aha! Thank you all!

Glad it was solved and yes, 1.3.x and later all store their settings in the same audacity.cfg file.

But 100 ms is the default audio to buffer and it’s expected to start failing on Windows below about 30 - 40 ms. I was assuming you had it on the default 100 ms and needed to put it up to about 200 ms.


The answer as to why it was set at 25 instead of 100+ is lost in the mists of time. In other words, a couple of years ago.

Another user error. Sigh.