Seriously Random Recording Issue

Heya, I wonder if any of you could help me out here? It was my last resort to make an account here, just to try to get to the bottom of this problem! I have tried to Google fixing this incredibly annoying issue I am having with recording commentaries. I was especially upset last night, after recording 3 hours of game footage, along with 3 hours of commentary, only to find that the audio is completely screwed up. (Sometimes) recorded audio will start to sound scratchy/bouncy, while fading in and out. It comes and goes randomly and I have managed to get through some recordings with no issues at all.

Here is a sample I uploaded to Soundcloud:

My setup is a new 2014 Macbook Pro (highest end model), an Elgato HD60 capture card is plugged into one USB (taking footage from my PS4) and I have a USB mic filling the other USB port.



Version of Audacity and version of Mac OS X? See the pink panel at the top. Audacity 2.0.6 does not officially support Yosemite.

Make and model number of the USB mic?

Have you tried turning the WiFi off?

Changing Audio to buffer in Audacity’s Recording Preferences might help. It defaults to 100 milliseconds but on modern OS X it is sometimes necessary to reduce that buffer setting rather than increasing it as you might expect.


Hello Gale, thanks for your response.

Audacity is running version 2.0.6, my Mac is Yosemite 10.10.2. I was not aware that Yosemite isn’t supported. What are the chances of something like this being the root of the problem?

The mic is part of a Turtle Beach headset (PX11). I do own professional quality microphones, though the Turtle Beach headset sounds just fine, when the software is performing as expected.

I must admit that WiFi may have been on the last time I recorded, though I think I have had the same problem when the WiFi has been off.

So if I am to trial changing the buffer settings, what would you recommend setting it to?


It’s slightly possible if you are recording into tracks that have already been used. You could drag 2.0.6 to trash and try 2.1.0-alpha from the top of The latest 2.1.0-alpha’s should be quite close to release ready and do have a fix to flush playback cache.

I can’t say any more than please experiment, but don’t be surprised if reducing the buffer helps.